see if we can satisfy lintian
[debian/p10cfgd] / debian / rules
index 294b29b6b3d6dd6843465f365332e2e1a4db1bcc..b91b51867b453577bd29e4510bddf15d662b78e3 100755 (executable)
@@ -1,58 +1,50 @@
 #!/usr/bin/make -f
-# Sample debian.rules file - for GNU Hello (1.3).
-# Copyright 1994,1995 by Ian Jackson.
-# I hereby give you perpetual unlimited permission to copy,
-# modify and relicense this file, provided that you do not remove
-# my name from the file itself.  (I assert my moral right of
-# paternity under the Copyright, Designs and Patents Act 1988.)
-# This file may have to be extensively modified
-
-# There used to be `source' and `diff' targets in this file, and many
-# packages also had `changes' and `dist' targets.  These functions
-# have been taken over by dpkg-source, dpkg-genchanges and
-# dpkg-buildpackage in a package-independent way, and so these targets
-# are obsolete.
-
-package=p10cfgd
-
-build:
-       $(checkdir)
-       touch build
 
-clean:
-       $(checkdir)
-       -rm -f build
-       -rm -rf *~ debian/tmp debian/*~ debian/files*
-
-binary-indep:  checkroot build
-       $(checkdir)
-
-binary-arch:   checkroot build
-       $(checkdir)
-       -rm -rf debian/tmp
-       install -d debian/tmp/usr/bin debian/tmp/usr/man/man1
-       install -g root -m 755 -o root p10cfgd debian/tmp/usr/bin/p10cfgd
-       install -g root -m 644 -o root p10cfgd \
-               debian/tmp/usr/man/man1/p10cfgd.1
-       debstd $(package) CHANGES INSTALL README* TODO
-       dpkg-gencontrol
-       chown -R root.root debian/tmp
-       chmod -R g-ws debian/tmp
-       dpkg --build debian/tmp ..
-
-define checkdir
-       test -f debian/rules
-endef
-
-# Below here is fairly generic really
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
 
-binary:                binary-indep binary-arch
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp:
+       dh_testdir
+       touch build-stamp
 
-source diff:
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp
+       dh_clean
+
+binary-indep: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+       install -g root -m 755 -o root p10cfgd debian/p10cfgd/usr/sbin/p10cfgd
+       install -g root -m 644 -o root p10cfgd \
+               debian/p10cfgd/usr/share/man/man1/p10cfgd.1
+       install -o root -g root -m 0644 debian/p10cfgd.lintian \
+               debian/p10cfgd/usr/share/lintian/overrides/p10cfgd
+       dh_installdocs
+       dh_installexamples examples/*
+       dh_installmenu
+       dh_installcron
+       dh_installchangelogs
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+
+binary-arch: build
+
+source diff:                                                                  
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary