prepare a 1.1 upstream release
[debian/p10cfgd] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100755 (executable)
index 294b29b..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian.rules file - for GNU Hello (1.3).
-# Copyright 1994,1995 by Ian Jackson.
-# I hereby give you perpetual unlimited permission to copy,
-# modify and relicense this file, provided that you do not remove
-# my name from the file itself.  (I assert my moral right of
-# paternity under the Copyright, Designs and Patents Act 1988.)
-# This file may have to be extensively modified
-
-# There used to be `source' and `diff' targets in this file, and many
-# packages also had `changes' and `dist' targets.  These functions
-# have been taken over by dpkg-source, dpkg-genchanges and
-# dpkg-buildpackage in a package-independent way, and so these targets
-# are obsolete.
-
-package=p10cfgd
-
-build:
-       $(checkdir)
-       touch build
-
-clean:
-       $(checkdir)
-       -rm -f build
-       -rm -rf *~ debian/tmp debian/*~ debian/files*
-
-binary-indep:  checkroot build
-       $(checkdir)
-
-binary-arch:   checkroot build
-       $(checkdir)
-       -rm -rf debian/tmp
-       install -d debian/tmp/usr/bin debian/tmp/usr/man/man1
-       install -g root -m 755 -o root p10cfgd debian/tmp/usr/bin/p10cfgd
-       install -g root -m 644 -o root p10cfgd \
-               debian/tmp/usr/man/man1/p10cfgd.1
-       debstd $(package) CHANGES INSTALL README* TODO
-       dpkg-gencontrol
-       chown -R root.root debian/tmp
-       chmod -R g-ws debian/tmp
-       dpkg --build debian/tmp ..
-
-define checkdir
-       test -f debian/rules
-endef
-
-# Below here is fairly generic really
-
-binary:                binary-indep binary-arch
-
-source diff:
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot