completely repackage as an installer only
[debian/openrocket] / debian / rules
index 4b02b0743cb8300a986f6843e65f44f3afc9de36..553d9b007f3f57d80ff46af702f09eaa45a6fed3 100755 (executable)
@@ -1,33 +1,7 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 %:
-       dh  $@
+       dh $@
 
-override_dh_auto_build:
-       ant -f core/build.xml dist-bin
-
-override_dh_auto_install:
-       cp core/build/jar/* `pwd`/debian/openrocket/usr/share/java/
-       printf '#!/bin/sh\nexec java -jar /usr/share/java/%s "$$@"\n' \
-               "`/bin/ls core/build/jar`" > \
-               `pwd`/debian/openrocket/usr/bin/openrocket 
-
-override_dh_installman:
-       dh_installman debian/openrocket.1
-
-override_dh_install:
-       install -o root -g root -m 644 core/resources/pix/icon/icon-032.png \
-               debian/openrocket/usr/share/pixmaps/openrocket.png
-       pngtopnm < core/resources/pix/icon/icon-032.png | ppmtoxpm > \
-               debian/openrocket/usr/share/pixmaps/openrocket.xpm
-       install -o root -g root -m 644 debian/openrocket.desktop \
-               debian/openrocket/usr/share/applications