fix lintian whines
authorBdale Garbee <bdale@gag.com>
Fri, 29 Jun 2012 13:41:57 +0000 (07:41 -0600)
committerBdale Garbee <bdale@gag.com>
Fri, 29 Jun 2012 13:41:57 +0000 (07:41 -0600)
debian/changelog
debian/control
debian/init.d
debian/rules

index 6bd5b8da54827a9b2f90d7bef1115c312fa318fd..758bd23499fce23b5342723d47d64442c7e4b669 100644 (file)
@@ -2,6 +2,8 @@ ipip (1.1.9) UNRELEASED; urgency=low
 
   * add Vcs entries to the control file
   * move gbp.conf to .git/
+  * turn on hardening build flags
+  * make lintian happier
 
  -- Bdale Garbee <bdale@gag.com>  Fri, 29 Jun 2012 07:31:05 -0600
 
index 7af35a392239b9017e3d243022802b647eec33e9..9d0b7e264ce19147d3c30f2ddac2d6704ad13aec 100644 (file)
@@ -9,7 +9,7 @@ Vcs-Browser: http://git.gag.com/?p=debian/ipip
 
 Package: ipip
 Architecture: any
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Description: IP over IP Encapsulation Daemon
  This daemon provides an alternative to the kernel-resident support for IP
  encapsulation links.  It is better suited for situations where there are many
index c5df38811cef99b97c4cae2241c533df0dc45711..34eaf8fdb23180bf4f2fb790155f9b0969577edb 100644 (file)
@@ -4,7 +4,7 @@
 # Required-Start:    $remote_fs $syslog
 # Required-Stop:     $remote_fs $syslog
 # Default-Start:     2 3 4 5
-# Default-Stop:      1
+# Default-Stop:      0 1 6
 # Short-Description: IP over IP encapsulation daemon 
 ### END INIT INFO
 
index f8b8e73673f1d214c3ad7379327bf16761a71b96..5b1a8613b34dfdf0aca32f8335a7587aec4c70bf 100755 (executable)
@@ -4,7 +4,14 @@
 
 # export DH_VERBOSE=1
 
-build: build-stamp
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp:
        dh_testdir
        $(MAKE)