Imported Upstream version 1.6
[debian/gzip] / tests / Makefile.am
index 3b6ec31c22ed4247e478910fbfb627a3c356e86e..53bfffa19021774a2740621129595e26c88483b6 100644 (file)
@@ -1,5 +1,5 @@
 ## Process this file with automake to create Makefile.in
-# Copyright 2010-2012 Free Software Foundation, Inc.
+# Copyright 2010-2013 Free Software Foundation, Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -18,13 +18,16 @@ TESTS =                                     \
   helin-segv                           \
   help-version                         \
   hufts                                        \
+  keep                                 \
   memcpy-abuse                         \
   mixed                                        \
   null-suffix-clobber                  \
   stdin                                        \
   trailing-nul                         \
+  unpack-invalid                       \
   zdiff                                        \
   zgrep-f                              \
+  zgrep-context                                \
   zgrep-signal                         \
   znew-k
 
@@ -67,23 +70,22 @@ TESTS_ENVIRONMENT =                         \
       $(SHELL) "$$1";                          \
     fi;                                                \
   };                                           \
-  export                                       \
-  LC_ALL=C                                     \
-  VERSION=$(VERSION)                           \
-  abs_top_builddir='$(abs_top_builddir)'       \
-  abs_top_srcdir='$(abs_top_srcdir)'           \
-  abs_srcdir='$(abs_srcdir)'                   \
-  built_programs='$(built_programs)'           \
-  srcdir='$(srcdir)'                           \
-  top_srcdir='$(top_srcdir)'                   \
-  CC='$(CC)'                                   \
-  GZIP_TEST_NAME=`echo $$tst|sed 's,^\./,,;s,/,-,g'` \
-  MAKE=$(MAKE)                                 \
-  PACKAGE_BUGREPORT='$(PACKAGE_BUGREPORT)'     \
-  PACKAGE_VERSION=$(PACKAGE_VERSION)           \
-  PERL='$(PERL)'                               \
-  SHELL='$(SHELL)'                             \
-  PATH='$(abs_top_builddir)$(PATH_SEPARATOR)'"$$PATH" \
-  ; 9>&2
+  LC_ALL=C; export LC_ALL;                                             \
+  VERSION=$(VERSION); export VERSION;                                          \
+  abs_top_builddir='$(abs_top_builddir)'; export abs_top_builddir;     \
+  abs_top_srcdir='$(abs_top_srcdir)'; export abs_top_srcdir;           \
+  abs_srcdir='$(abs_srcdir)'; export abs_srcdir;                       \
+  built_programs='$(built_programs)'; export built_programs;           \
+  srcdir='$(srcdir)'; export srcdir;                                   \
+  top_srcdir='$(top_srcdir)'; export top_srcdir;                       \
+  CC='$(CC)'; export CC;                                               \
+  GZIP_TEST_NAME=`echo $$tst|sed 's,^\./,,;s,/,-,g'`; export GZIP_TEST_NAME; \
+  MAKE=$(MAKE); export MAKE;                                           \
+  PACKAGE_BUGREPORT='$(PACKAGE_BUGREPORT)'; export PACKAGE_BUGREPORT;  \
+  PACKAGE_VERSION=$(PACKAGE_VERSION); export PACKAGE_VERSION;          \
+  PERL='$(PERL)'; export PERL;                                         \
+  SHELL='$(SHELL)'; export SHELL;                                      \
+  PATH='$(abs_top_builddir)$(PATH_SEPARATOR)'"$$PATH"; export PATH;    \
+  9>&2
 
 VERBOSE = yes