turn on regression test suite
[debian/gzip] / debian / rules
index a8c932ce12db443dbae0b5f4bb191e8fd4a9abe8..18290b24c243ad29aff98ee4b59afc24a58295ed 100755 (executable)
@@ -46,6 +46,11 @@ build-arch: build-stamp
 build-stamp: configure-stamp
        dh_testdir
        $(MAKE) -C build
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+       $(MAKE) check
+endif
+endif
        touch build-stamp
 
 build-indep: build-indep-stamp