New upstream version 1.9
[debian/gzip] / Makefile.am
index 738c63ca17115150ba2a7d09d3a33d80840622e3..d4ecc3f18a018e3c57a179a55e3483a566c917dd 100644 (file)
@@ -1,6 +1,6 @@
 # Make gzip (GNU zip).
 
-# Copyright (C) 1999, 2001-2002, 2006-2007, 2009-2016 Free Software Foundation,
+# Copyright (C) 1999, 2001-2002, 2006-2007, 2009-2018 Free Software Foundation,
 # Inc.
 
 # This program is free software; you can redistribute it and/or modify
@@ -80,12 +80,13 @@ gzip.doc.gz: gzip.doc $(bin_PROGRAMS)
 
 SUFFIXES = .in
 .in:
-       $(AM_V_GEN)sed \
+       $(AM_V_GEN)rm -f $@-t $@ \
+          && sed \
                -e 's|/bin/sh|$(SHELL)|g' \
                -e 's|[@]GREP@|$(GREP)|g' \
                -e 's|[@]VERSION@|$(VERSION)|g' \
                $(srcdir)/$@.in >$@-t \
-         && chmod a+x $@-t \
+         && chmod a=rx $@-t \
          && mv $@-t $@
 
 # Arrange so that .tarball-version appears only in the distribution