Merge commit 'v3.3.0' into upstream
[debian/gnuradio] / usrp2 / host / lib / Makefile.am
index 772cf1446d80739753f99ebceaa7bf2b2f6a5bff..209cb70953d88886b2aa1759c88cde1f443c8cbd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2007,2008 Free Software Foundation, Inc.
+# Copyright 2007,2008,2010 Free Software Foundation, Inc.
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -30,6 +30,8 @@ usrp2_socket_opener_SOURCES = usrp2_socket_opener.cc
 lib_LTLIBRARIES = \
        libusrp2.la
 
+libusrp2_la_LDFLAGS = $(LTVERSIONFLAGS)
+
 libusrp2_la_SOURCES = \
        control.cc \
        copiers.cc \
@@ -45,11 +47,9 @@ libusrp2_la_SOURCES = \
        rx_sample_handler.cc \
        strtod_si.c \
        usrp2.cc \
-       usrp2_impl.cc \
-       usrp2_thread.cc
+       usrp2_impl.cc
 
 libusrp2_la_LIBADD = \
-       $(OMNITHREAD_LA) \
        $(GRUEL_LA) \
        $(BOOST_LDFLAGS) $(BOOST_THREAD_LIB)
 
@@ -63,5 +63,4 @@ noinst_HEADERS = \
        pktfilter.h \
        ring.h \
        usrp2_bytesex.h \
-       usrp2_impl.h \
-       usrp2_thread.h
+       usrp2_impl.h
\ No newline at end of file