Merge branch 'dfsg-orig'
[debian/gnuradio] / gr-cvsd-vocoder / src / lib / Makefile.am
index 78a7c6400ecbacf95e8b003e47607eb92ae1602c..c5957f4acc7cbabd21e7d8e0f33562de877d44f4 100644 (file)
@@ -28,6 +28,18 @@ grinclude_HEADERS =                  \
        cvsd_decode_bs.h                \
        cvsd_encode_sb.h
 
+lib_LTLIBRARIES = libgnuradio-cvsd-vocoder.la
+
+libgnuradio_cvsd_vocoder_la_SOURCES =  \
+       cvsd_decode_bs.cc               \
+       cvsd_encode_sb.cc
+
+libgnuradio_cvsd_vocoder_la_LIBADD =   \
+       $(GNURADIO_CORE_LA)
+
+libgnuradio_cvsd_vocoder_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
+
+if PYTHON
 ###################################
 # SWIG Python interface and library
 
@@ -41,14 +53,9 @@ TOP_SWIG_IFILES =                    \
 cvsd_vocoder_pythondir_category =      \
        gnuradio/vocoder
 
-# additional sources for the SWIG-generated library
-cvsd_vocoder_la_swig_sources =         \
-       cvsd_decode_bs.cc               \
-       cvsd_encode_sb.cc
-
 # additional libraries for linking with the SWIG-generated library
 cvsd_vocoder_la_swig_libadd =          \
-       $(GNURADIO_CORE_LA)
+       libgnuradio-cvsd-vocoder.la
 
 include $(top_srcdir)/Makefile.swig
 
@@ -57,3 +64,4 @@ BUILT_SOURCES = $(swig_built_sources)
 
 # Do not distribute the output of SWIG
 no_dist_files = $(swig_built_sources)
+endif