Merge branch 'dfsg-orig'
[debian/gnuradio] / gr-audio-alsa / src / Makefile.am
index 8230ab56999dee5c0173765c0e6042b8cdf25e6e..ed92cc197dece844e39c5c9a76f73dc46d51cbef 100644 (file)
@@ -23,10 +23,6 @@ include $(top_srcdir)/Makefile.common
 
 EXTRA_DIST = run_tests.in
 
-TESTS = run_tests
-
-DISTCLEANFILES = run_tests
-
 # C/C++ headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =                    \
        audio_alsa_sink.h               \
@@ -54,11 +50,13 @@ libgnuradio_audio_alsa_la_LIBADD =  \
        $(GNURADIO_CORE_LA)             \
        $(ALSA_LIBS)
 
-libgnuradio_audio_alsa_la_LDFLAGS =    \
-       $(NO_UNDEFINED)
+libgnuradio_audio_alsa_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
+if PYTHON
 ###################################
 # SWIG Python interface and library
+TESTS = run_tests
+DISTCLEANFILES = run_tests
 
 TOP_SWIG_IFILES =                      \
        audio_alsa.i
@@ -81,3 +79,4 @@ BUILT_SOURCES = $(swig_built_sources)
 
 # Do not distribute the output of SWIG
 no_dist_files = $(swig_built_sources)
+endif
\ No newline at end of file