Imported Debian patch 3.12-3.1
[debian/elilo] / x86_64 / Makefile
index 7ade312780dedf7f4ad9ceb20f7c448c92ea3f44..4af4b8d9448cec31ac7fe906d2fdef5903ca6ac1 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
 #FILES=system.o config.o plain_loader.o
@@ -43,13 +38,13 @@ all: $(TARGET)
 system.o: rmswitch.h
 
 rmswitch.h: bin_to_h.c rmswitch.S
-       $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
-       $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
+       $(CC) -o bin_to_h bin_to_h.c
+       $(AS) -o rmswitch.o rmswitch.S
        $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
        ./bin_to_h <rmswitch >rmswitch.h
 
 $(TARGET): $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)