Imported Debian patch 3.12-3.1
[debian/elilo] / ia32 / Makefile
index c5f421b4ed8090833104dbc5b9c72bf8c9b50aab..353ae6791dffb98d8803a5ee148d313d01e09fee 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
 
@@ -42,13 +37,13 @@ all: $(TARGET)
 system.o: rmswitch.h
 
 rmswitch.h: bin_to_h.c rmswitch.S
-       $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
-       $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
+       $(CC) -o bin_to_h bin_to_h.c
+       $(AS) -o rmswitch.o rmswitch.S
        $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
        ./bin_to_h <rmswitch >rmswitch.h
 
 $(TARGET): $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)