Imported Debian patch 3.12-3.1
[debian/elilo] / fs / Makefile
index 4c26f713ea9f4563b77916605c276eadb088ac94..1829d967cee4edfd9b50389c58b82e14b4fd4b13 100644 (file)
 # to use this program.
 #
 
-SRCDIR = .
-
-VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-include $(SRCDIR)/../Make.rules
-
-TOPDIR=$(SRCDIR)/..
+include ../Make.defaults
+include ../Make.rules
 
+TOPDIR=$(CDIR)/..
 
 FILES=
 ifeq ($(CONFIG_localfs),y)
@@ -60,7 +55,7 @@ all: $(TARGET)
 #      without doing make clean.
 #
 $(TARGET): check-filesystems $(TOPDIR)/Make.defaults $(FILES)
-       $(LD) $(LD3264) -r -o $@ $(FILES)
+       $(LD) -r -o $@ $(FILES)
 
 clean:
        $(RM) -f $(TARGET) $(FILES)