rename patch set from 3.12-3 to reflect purpose
[debian/elilo] / debian / patches / debian-changes-3.12-3
diff --git a/debian/patches/debian-changes-3.12-3 b/debian/patches/debian-changes-3.12-3
deleted file mode 100644 (file)
index f632a23..0000000
+++ /dev/null
@@ -1,284 +0,0 @@
-Description: Upstream changes introduced in version 3.12-3
- This patch has been created by dpkg-source during the package build.
- Here's the last changelog entry, hopefully it gives details on why
- those changes were made:
- .
- elilo (3.12-3) unstable; urgency=low
- .
-   * fix paths and options to build both 32 and 64 bit versions on either
-     flavor of build host, closes: #574713
-   * don't generate noise when following symlink since that's now the normal
-     situation, closes: #581068
- .
- The person named in the Author field signed this changelog entry.
-Author: Bdale Garbee <bdale@gag.com>
-Bug-Debian: http://bugs.debian.org/574713
-Bug-Debian: http://bugs.debian.org/581068
-
----
-The information above should follow the Patch Tagging Guidelines, please
-checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
-are templates for supplementary fields that you might want to add:
-
-Origin: <vendor|upstream|other>, <url of original patch>
-Bug: <url in upstream bugtracker>
-Bug-Debian: http://bugs.debian.org/<bugnumber>
-Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
-Forwarded: <no|not-needed|url proving that it has been forwarded>
-Reviewed-By: <name and email of someone who approved the patch>
-Last-Update: <YYYY-MM-DD>
-
---- elilo-3.12.orig/Makefile
-+++ elilo-3.12/Makefile
-@@ -25,15 +25,19 @@
- # to use this program.
- #
--include Make.defaults
--TOPDIR=.
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/Make.defaults
-+TOPDIR = $(SRCDIR)
- CRTOBJS       = $(EFICRT0)/crt0-efi-$(ARCH).o
- LDSCRIPT      = $(EFICRT0)/elf_$(ARCH)_efi.lds
- LDFLAGS            += -T $(LDSCRIPT) -shared -Bsymbolic -L$(EFILIB) -L$(GNUEFILIB) $(CRTOBJS)
--LOADLIBES     = -lefi -lgnuefi $(shell $(CC) -print-libgcc-file-name)
-+LOADLIBES     = -lefi -lgnuefi $(shell $(CC) $(ARCH3264) -print-libgcc-file-name)
- FORMAT        = efi-app-$(ARCH)
- FILESYSTEM    =
-@@ -87,7 +91,8 @@ fileops.o : Make.defaults
- chooser.o : Make.defaults
- $(SUBDIRS): dummy
--      $(MAKE) -C $@
-+      mkdir -p $@
-+      $(MAKE) -C $@ -f $(SRCDIR)/../$@/Makefile SRCDIR=$(SRCDIR)/../$@ ARCH=$(ARCH)
- dummy:
-@@ -106,4 +111,4 @@ ifeq ($(GCC_VERSION),2)
-       @exit 1
- endif
--include Make.rules
-+include $(SRCDIR)/Make.rules
---- elilo-3.12.orig/devschemes/Makefile
-+++ elilo-3.12/devschemes/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=simple.o
-@@ -40,7 +45,7 @@ all: $(TARGET)
- #      without doing make clean.
- #
- $(TARGET): $(FILES)
--      $(LD) -r -o $@ $(FILES)
-+      $(LD) $(LD3264) -r -o $@ $(FILES)
- clean:
-       $(RM) -f $(TARGET) $(FILES)
---- elilo-3.12.orig/ia64/Makefile
-+++ elilo-3.12/ia64/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=system.o config.o fpswa.o plain_loader.o gzip_loader.o \
-       gzip.o memset.o memcpy.o setjmp.o longjmp.o
---- elilo-3.12.orig/choosers/Makefile
-+++ elilo-3.12/choosers/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=
-@@ -43,11 +48,11 @@ TARGET=choosers.o
- all: $(TARGET)
- $(TARGET): check-choosers $(TOPDIR)/Make.defaults $(FILES)
--      $(LD) -o $@ -r $(FILES)
-+      $(LD) $(LD3264) -o $@ -r $(FILES)
- clean:
-       $(RM) -f $(TARGET) $(FILES)
--      
-+
- check-choosers:
-       @if [ -n "$(FILES)" ]; then \
-               exit 0; \
---- elilo-3.12.orig/ia32/Makefile
-+++ elilo-3.12/ia32/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
-@@ -37,13 +42,13 @@ all: $(TARGET)
- system.o: rmswitch.h
- rmswitch.h: bin_to_h.c rmswitch.S
--      $(CC) -o bin_to_h bin_to_h.c
--      $(AS) -o rmswitch.o rmswitch.S
-+      $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
-+      $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
-       $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
-       ./bin_to_h <rmswitch >rmswitch.h
- $(TARGET): $(FILES)
--      $(LD) -r -o $@ $(FILES)
-+      $(LD) $(LD3264) -r -o $@ $(FILES)
- clean:
-       $(RM) -f $(TARGET) $(FILES)
---- elilo-3.12.orig/x86_64/Makefile
-+++ elilo-3.12/x86_64/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=system.o config.o bzimage.o plain_loader.o gzip_loader.o gzip.o
- #FILES=system.o config.o plain_loader.o
-@@ -38,13 +43,13 @@ all: $(TARGET)
- system.o: rmswitch.h
- rmswitch.h: bin_to_h.c rmswitch.S
--      $(CC) -o bin_to_h bin_to_h.c
--      $(AS) -o rmswitch.o rmswitch.S
-+      $(CC) -o bin_to_h $(SRCDIR)/bin_to_h.c
-+      $(AS) -o rmswitch.o $(SRCDIR)/rmswitch.S
-       $(LD) -Ttext 0x0 -s --oformat binary -o rmswitch rmswitch.o
-       ./bin_to_h <rmswitch >rmswitch.h
- $(TARGET): $(FILES)
--      $(LD) -r -o $@ $(FILES)
-+      $(LD) $(LD3264) -r -o $@ $(FILES)
- clean:
-       $(RM) -f $(TARGET) $(FILES)
---- elilo-3.12.orig/tools/Makefile
-+++ elilo-3.12/tools/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=eliloalt.o
- TARGET=eliloalt
---- elilo-3.12.orig/fs/Makefile
-+++ elilo-3.12/fs/Makefile
-@@ -23,10 +23,15 @@
- # to use this program.
- #
--include ../Make.defaults
--include ../Make.rules
-+SRCDIR = .
-+
-+VPATH = $(SRCDIR)
-+
-+include $(SRCDIR)/../Make.defaults
-+include $(SRCDIR)/../Make.rules
-+
-+TOPDIR=$(SRCDIR)/..
--TOPDIR=$(CDIR)/..
- FILES=
- ifeq ($(CONFIG_localfs),y)
-@@ -55,7 +60,7 @@ all: $(TARGET)
- #      without doing make clean.
- #
- $(TARGET): check-filesystems $(TOPDIR)/Make.defaults $(FILES)
--      $(LD) -r -o $@ $(FILES)
-+      $(LD) $(LD3264) -r -o $@ $(FILES)
- clean:
-       $(RM) -f $(TARGET) $(FILES)