Imported Debian patch 0.5.4-1
[debian/efibootmgr] / src / efibootmgr / module.mk
index dac4907e8b486a718e2da313abcceb048f8ddb72..790e2e4bb206ae97f09045107404163b5e4eb80d 100644 (file)
@@ -11,7 +11,7 @@ efibootmgr_LIBS    := crc32.o disk.o efi.o efichar.o gpt.o scsi_ioctls.o \
 efibootmgr_LIBDIR  := src/lib
 efibootmgr_FULLLIB := \
        $(patsubst %,$(efibootmgr_LIBDIR)/%,$(efibootmgr_LIBS))
-LIBS = -lpci
+LIBS = -lpci -lz
 
 ALLDEPS += $(efibootmgr_FULLTARGET)
 CLEANLIST += $(efibootmgr_FULLTARGET)
@@ -20,5 +20,5 @@ bindir_TARGETS += $(efibootmgr_FULLTARGET)
 
 $(efibootmgr_FULLTARGET): \
        $(efibootmgr_FULLOBJECT) \
-       $(efibootmgr_FULLLIB) \
-       $(LIBS)
+       $(efibootmgr_FULLLIB)
+       $(CC) $(CFLAGS) $(LDFLAGS) $(efibootmgr_SRCDIR)/efibootmgr.c $^ $(LIBS) -o $@