Imported Debian patch 0.4.9-0.sarge.2
[debian/efibootmgr] / src / efibootmgr / module.mk
index 7764641743e4a318a3a395f0e214cdd94e06dece..069a6485f8e1520f629cd6c4c22657a16670614d 100644 (file)
@@ -2,21 +2,21 @@ efibootmgr_SRCDIR := src/efibootmgr
 efibootmgr_OBJECTS := efibootmgr.o
 efibootmgr_TARGETS := efibootmgr
 efibootmgr_FULLTARGET :=  \
-       $(patsubst %, $(efibootmgr_SRCDIR)/%, $(efibootmgr_TARGETS))
+       $(patsubst %, $(efibootmgr_SRCDIR)/%, $(efibootmgr_TARGETS))
 efibootmgr_FULLOBJECT :=  \
-       $(patsubst %, $(efibootmgr_SRCDIR)/%, $(efibootmgr_OBJECT))
+       $(patsubst %, $(efibootmgr_SRCDIR)/%, $(efibootmgr_OBJECT))
 
 efibootmgr_LIBS    := crc32.o disk.o efi.o efichar.o gpt.o scsi_ioctls.o \
-                      unparse_path.o
+                      unparse_path.o efivars_procfs.o efivars_sysfs.o
 efibootmgr_LIBDIR  := src/lib
 efibootmgr_FULLLIB := \
-       $(patsubst %,$(efibootmgr_LIBDIR)/%,$(efibootmgr_LIBS))
+       $(patsubst %,$(efibootmgr_LIBDIR)/%,$(efibootmgr_LIBS))
 
-ALLDEPS += $(efibootmgr_FULLTARGET) 
+ALLDEPS += $(efibootmgr_FULLTARGET)
 CLEANLIST += $(efibootmgr_FULLTARGET)
 CLEANLIST += $(efibootmgr_FULLOBJECT)
-bindir_TARGETS += $(efibootmgr_FULLTARGET) 
+bindir_TARGETS += $(efibootmgr_FULLTARGET)
 
 $(efibootmgr_FULLTARGET): \
-       $(efibootmgr_FULLOBJECT) \
-       $(efibootmgr_FULLLIB)
+       $(efibootmgr_FULLOBJECT) \
+       $(efibootmgr_FULLLIB)