move to dh, etc
[debian/efibootmgr] / debian / rules
index cd1592155076c240bd1a3a764e09a56459ef2ae4..1e214a22fd0153e1329ea6c8e8809366c2e579d4 100755 (executable)
@@ -1,57 +1,8 @@
 #!/usr/bin/make -f
+# rules file for the efibootmgr package, requires debhelper / dh
+# copyright 2012 by Bdale Garbee, GPLv2 or later
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
+export DH_VERBOSE=1
 
-       touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       $(MAKE) clean
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       cp src/efibootmgr/efibootmgr debian/efibootmgr/bin/efibootmgr
-       chown root:root debian/efibootmgr/bin/efibootmgr
-       chmod 0755 debian/efibootmgr/bin/efibootmgr
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-       dh_installcron
-       dh_installman src/man/man8/efibootmgr.8
-       dh_installinfo
-       dh_installchangelogs doc/ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+%:
+       dh $@