New upstream version 2.20
[debian/cpmtools] / configure.in
index 0632ff7a87827295df3bba32ba21fa12b583da3e..be9a55c8c3bf5a9d748f2e599e2ce725d34d238c 100644 (file)
@@ -1,8 +1,8 @@
 AC_INIT(cpmfs.c)
 AC_CONFIG_HEADER(config.h)
 AC_CANONICAL_HOST
-VERSION=2.17
-UPDATED='November 16, 2013'
+VERSION=2.20
+UPDATED='October 25, 2014'
 
 DEVICE="posix"
 
@@ -23,7 +23,7 @@ AC_PROG_CPP
 
 if test "$GCC" = yes
 then
-  CFLAGS="${CFLAGS} ${EXTRA_GCFLAGS}-pipe -Wall -Wno-unused -Wshadow -Wbad-function-cast -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wpointer-arith -Wwrite-strings -Wmissing-declarations -Wnested-externs -Wundef -pedantic -fno-common"
+  CFLAGS="${CFLAGS} ${EXTRA_GCFLAGS}-pipe -Wall -Wextra -Wno-unused-parameter -Wno-unused -Wshadow -Wbad-function-cast -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wpointer-arith -Wwrite-strings -Wmissing-declarations -Wnested-externs -Wundef -pedantic -fno-common"
   LDFLAGS="${LDFLAGS} ${EXTRA_GLDFLAGS}-g"
 else
   CFLAGS="${CFLAGS} ${EXTRA_CFLAGS}"
@@ -65,6 +65,10 @@ dnl Try both curses and ncurses
 AC_CHECK_LIB(curses, printw, FSED_CPM=fsed.cpm LIBS="-lcurses $LIBS", FSED_CPM=)
 if test x"$FSED_CPM" = x""; then
   AC_CHECK_LIB(ncurses, printw, FSED_CPM=fsed.cpm LIBS="-lncurses $LIBS", FSED_CPM=)
+  if test x"$FSED_CPM" != x""; then
+    AC_DEFINE(NEED_NCURSES)
+    AC_CHECK_HEADERS(ncurses/ncurses.h,have_ncurses_ncurses_h=yes)
+  fi
 fi
 
 dnl If using libdsk, check it's available.