Imported Upstream version 2.10
[debian/cpmtools] / configure.in
index b9d19d6f8fae13d0e9c6aa1e9a8a8c10ff57155f..8a6e47fc8cfa0a0577461468595c8ede47ce94f1 100644 (file)
@@ -1,8 +1,8 @@
 AC_INIT(cpmfs.c)
 AC_CONFIG_HEADER(config.h)
 AC_CANONICAL_HOST
-VERSION=2.1
-UPDATED='April 21, 2002'
+VERSION=2.10
+UPDATED='July 6, 2009'
 
 DEVICE="posix"
 
@@ -10,12 +10,6 @@ if test "$prefix" = NONE
 then
   case $host in
     *-linux-*)
-      PIPE="-pipe "
-    ;;
-  esac
-  case $host in
-    *-netbsd*)
-      PIPE="-pipe "
     ;;
   esac
 fi
@@ -26,31 +20,42 @@ AC_PROG_CPP
 
 if test "$GCC" = yes
 then
-  CFLAGS="${CFLAGS} ${PIPE}-Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common"
-  LDFLAGS='-g'
+  CFLAGS="${CFLAGS} ${EXTRA_GCFLAGS}-pipe -Wall -Wno-unused -Wshadow -Wbad-function-cast -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wpointer-arith -Wwrite-strings -Wmissing-declarations -Wnested-externs -Wundef -pedantic -fno-common"
+  LDFLAGS="${LDFLAGS} ${EXTRA_GLDFLAGS}-g"
+else
+  CFLAGS="${CFLAGS} ${EXTRA_CFLAGS}"
+  LDFLAGS="${LDFLAGS} ${EXTRA_LDFLAGS}"
 fi
 
-AC_ARG_WITH(defformat,[  --with-defformat        Specify default format (ibm-3740)], 
-               [DEFFORMAT="$withval"], [DEFFORMAT="ibm-3740"])
-AC_ARG_WITH(libdsk,   [  --with-libdsk           Specify path to libdsk library], 
-               [LIBDSK="$withval"], [LIBDSK=""])
-AC_ARG_WITH(dmalloc,  [  --with-dmalloc          Specify path to dmalloc library], 
-               [DMALLOC="$withval"], [DMALLOC=""])
-
 AC_CYGWIN
 AC_MINGW32
 dnl Choose between posix and win32 drivers...
 DEVICE="posix"
 
+DISKDEFS='${datarootdir}/diskdefs'
+
 if test "$CYGWIN" = "yes"
 then
   DEVICE="win32"
+#  DISKDEFS='%USERPROFILE%/diskdefs'
 fi
 if test "$MINGW32" = "yes"
 then
   DEVICE="win32"
+#  DISKDEFS='%USERPROFILE%\\diskdefs'
 fi
 
+AC_ARG_WITH(diskdefs,[  --with-diskdefs         Specify diskdefs location], 
+               [DISKDEFS="$withval"], [DISKDEFS="$DISKDEFS"])
+AC_ARG_WITH(defformat,[  --with-defformat        Specify default format (ibm-3740)], 
+               [DEFFORMAT="$withval"], [DEFFORMAT="ibm-3740"])
+AC_ARG_WITH(libdsk,   [  --with-libdsk           Specify path to libdsk library], 
+               [LIBDSK="$withval"], [LIBDSK=""])
+AC_ARG_WITH(dmalloc,  [  --with-dmalloc          Specify path to dmalloc library], 
+               [CPPFLAGS="$CPPFLAGS -I$with_dmalloc/include"
+                 LDFLAGS="$LDFLAGS -L$with_dmalloc/lib"
+                 LIBS="$LIBS -ldmalloc"
+                 AC_DEFINE(USE_DMALLOC)])
 
 dnl Check for curses. If not found, don't build fsed.cpm
 dnl Try both curses and ncurses
@@ -74,16 +79,6 @@ if test x"$DEVICE" = x"win32"; then
   AC_CHECK_HEADERS(windows.h winioctl.h, ,[echo "Windows headers not found - aborting"; exit 1] )
 fi
 
-dnl Check for dmalloc
-if test x"$DMALLOC" != x""; then
-   CPPFLAGS  = "-I$DMALLOC/include $CPPFLAGS"
-   CFLAGS  = "-I$DMALLOC/include $CFLAGS"
-   LDFLAGS = "-L$DMALLOC/lib $LDFLAGS"
-   AC_CHECK_LIB(dmalloc, malloc)
-   AC_CHECK_HEADERS(dmalloc.h)
-fi
-
-
 dnl Checks for header files.
 AC_HEADER_STDC
 AC_CHECK_HEADERS(fcntl.h sys/types.h sys/stat.h limits.h unistd.h)
@@ -97,6 +92,7 @@ AC_TYPE_SIZE_T
 AC_STRUCT_TM
 AC_EXEEXT
 AC_OBJEXT
+AC_SYS_LARGEFILE
 
 dnl add EXE extension to fsed.cpm
 if test x"$FSED_CPM" != x""; then