prepare to upload
[debian/cpmtools] / configure.in
index aec7ef97f405e7cde7facb9f03d0390925f43f12..17025c00727bb1bbb99d9bec4e94c0781cd10b61 100644 (file)
@@ -1,8 +1,8 @@
 AC_INIT(cpmfs.c)
 AC_CONFIG_HEADER(config.h)
 AC_CANONICAL_HOST
-VERSION=2.4
-UPDATED='Oct 6, 2004'
+VERSION=2.7
+UPDATED='November 26, 2007'
 
 DEVICE="posix"
 
@@ -10,12 +10,6 @@ if test "$prefix" = NONE
 then
   case $host in
     *-linux-*)
-      PIPE="-pipe "
-    ;;
-  esac
-  case $host in
-    *-netbsd*)
-      PIPE="-pipe "
     ;;
   esac
 fi
@@ -26,8 +20,11 @@ AC_PROG_CPP
 
 if test "$GCC" = yes
 then
-  CFLAGS="${CFLAGS} ${PIPE}-Wmissing-prototypes -Wstrict-prototypes -Wcast-qual -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wnested-externs -pedantic -fno-common"
-  LDFLAGS='-g'
+  CFLAGS="${CFLAGS} ${EXTRA_GCFLAGS}-pipe -Wall -Wno-unused -Wshadow -Wbad-function-cast -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wpointer-arith -Wwrite-strings -Wmissing-declarations -Wnested-externs -Wundef -pedantic -fno-common"
+  LDFLAGS="${LDFLAGS} ${EXTRA_GLDFLAGS}-g"
+else
+  CFLAGS="${CFLAGS} ${EXTRA_CFLAGS}"
+  LDFLAGS="${LDFLAGS} ${EXTRA_LDFLAGS}"
 fi
 
 AC_ARG_WITH(defformat,[  --with-defformat        Specify default format (ibm-3740)], 
@@ -35,7 +32,10 @@ AC_ARG_WITH(defformat,[  --with-defformat        Specify default format (ibm-374
 AC_ARG_WITH(libdsk,   [  --with-libdsk           Specify path to libdsk library], 
                [LIBDSK="$withval"], [LIBDSK=""])
 AC_ARG_WITH(dmalloc,  [  --with-dmalloc          Specify path to dmalloc library], 
-               [DMALLOC="$withval"], [DMALLOC=""])
+               [CPPFLAGS="$CPPFLAGS -I$with_dmalloc/include"
+                 LDFLAGS="$LDFLAGS -L$with_dmalloc/lib"
+                 LIBS="$LIBS -ldmalloc"
+                 AC_DEFINE(USE_DMALLOC)])
 
 AC_CYGWIN
 AC_MINGW32
@@ -74,16 +74,6 @@ if test x"$DEVICE" = x"win32"; then
   AC_CHECK_HEADERS(windows.h winioctl.h, ,[echo "Windows headers not found - aborting"; exit 1] )
 fi
 
-dnl Check for dmalloc
-if test x"$DMALLOC" != x""; then
-   CPPFLAGS  = "-I$DMALLOC/include $CPPFLAGS"
-   CFLAGS  = "-I$DMALLOC/include $CFLAGS"
-   LDFLAGS = "-L$DMALLOC/lib $LDFLAGS"
-   AC_CHECK_LIB(dmalloc, malloc)
-   AC_CHECK_HEADERS(dmalloc.h)
-fi
-
-
 dnl Checks for header files.
 AC_HEADER_STDC
 AC_CHECK_HEADERS(fcntl.h sys/types.h sys/stat.h limits.h unistd.h)
@@ -97,6 +87,7 @@ AC_TYPE_SIZE_T
 AC_STRUCT_TM
 AC_EXEEXT
 AC_OBJEXT
+AC_SYS_LARGEFILE
 
 dnl add EXE extension to fsed.cpm
 if test x"$FSED_CPM" != x""; then