fix upstream version, text displayed in help command
authorBdale Garbee <bdale@gag.com>
Thu, 12 Jan 2012 04:13:04 +0000 (21:13 -0700)
committerBdale Garbee <bdale@gag.com>
Thu, 12 Jan 2012 04:13:04 +0000 (21:13 -0700)
as31/as31.c
configure.in
debian/changelog
debian/patches/helptext [new file with mode: 0644]
debian/patches/series
debian/patches/update-version [new file with mode: 0644]

index 8e5580c66df661c11a06391ab6009043680cc37a..f4e2515e0dbed5697166d049ef94a0f4d03c5a79 100644 (file)
@@ -77,7 +77,6 @@ int main(int argc, char **argv)
 void showhelp(const char *cmd)
 {
        fprintf(stderr, "AS31 %s\n", VERSION);
-       fprintf(stderr, "Please report problems to: paul@pjrc.com\n\n");
        fprintf(stderr,
                "Usage: %s [-h] [-l] [-s] [-v] [-Aarg] [-Ffmt] [-Ofile] file.asm\n\n",
                cmd);
index db02e3e2ddfb43b82a990b30c022fab4d654d746..2850a22a199f99097471f0c9fef05089df70836d 100644 (file)
@@ -1,5 +1,5 @@
 AC_INIT(as31/as31.c)
-AM_INIT_AUTOMAKE(as31, 2.3.0)
+AM_INIT_AUTOMAKE(as31, 2.3.1)
 
 dnl ********************************************************************
 dnl Minimal Requirements
index d02fdec87507104b70852e7513aa6b87b19b055a..72f0a0244f81123d36473a5b54717834c000c534 100644 (file)
@@ -1,6 +1,8 @@
 as31 (2.3.1-6) UNRELEASED; urgency=low
 
   * patch from Jim Paris for issue in include parsing, closes: #655533
+  * fix upstream version in configure.in, elide obsolete upstream bug report
+    address from help text, closes: #655534
 
  -- Bdale Garbee <bdale@gag.com>  Wed, 11 Jan 2012 18:06:31 -0700
 
diff --git a/debian/patches/helptext b/debian/patches/helptext
new file mode 100644 (file)
index 0000000..df384e3
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/as31/as31.c b/as31/as31.c
+index 8e5580c..f4e2515 100644
+--- a/as31/as31.c
++++ b/as31/as31.c
+@@ -77,7 +77,6 @@ int main(int argc, char **argv)
+ void showhelp(const char *cmd)
+ {
+       fprintf(stderr, "AS31 %s\n", VERSION);
+-      fprintf(stderr, "Please report problems to: paul@pjrc.com\n\n");
+       fprintf(stderr,
+               "Usage: %s [-h] [-l] [-s] [-v] [-Aarg] [-Ffmt] [-Ofile] file.asm\n\n",
+               cmd);
index 594f70a30c2aced284a6356712f4668d8b620575..55dcc4bcdf6edd72a000666eebb70b876b0fa762 100644 (file)
@@ -2,3 +2,5 @@ elide_errant_text
 regenerate_parser.c
 as31-mkstemps.patch
 as31-fix-duplicate-line.patch
+update-version
+helptext
diff --git a/debian/patches/update-version b/debian/patches/update-version
new file mode 100644 (file)
index 0000000..35f82d7
--- /dev/null
@@ -0,0 +1,11 @@
+diff --git a/configure.in b/configure.in
+index db02e3e..2850a22 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1,5 +1,5 @@
+ AC_INIT(as31/as31.c)
+-AM_INIT_AUTOMAKE(as31, 2.3.0)
++AM_INIT_AUTOMAKE(as31, 2.3.1)
+ dnl ********************************************************************
+ dnl Minimal Requirements