Imported Upstream version 2.6.0
[debian/amanda] / recover-src / Makefile.am
index ac37b7300e7dd9934e684b287c17701d5e029143..5face92160014e52cec0c9a4d63319b5b0c33f49 100644 (file)
@@ -1,10 +1,16 @@
 # Makefile for Amanda file recovery programs.
 
+include $(top_srcdir)/config/automake/installperms.am
+include $(top_srcdir)/config/automake/precompile.am
+
 INCLUDES =     -I$(top_builddir)/common-src \
                -I$(top_srcdir)/common-src   \
                -I$(top_srcdir)/client-src   \
                -I$(top_srcdir)/gnulib
 
+AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
+AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
+
 LINT=@AMLINT@
 LINTFLAGS=@AMLINTFLAGS@
 
@@ -12,10 +18,6 @@ LIB_EXTENSION = la
 
 sbin_PROGRAMS =                amrecover
 
-if WANT_RUNTIME_PSEUDO_RELOC
-AM_LDFLAGS = -Wl,-enable-runtime-pseudo-reloc
-endif
-
 ###
 # Because libamanda includes routines (e.g. regex) provided by some system
 # libraries, and because of the way libtool sets up the command line, we
@@ -25,10 +27,10 @@ endif
 
 LDADD = ../common-src/libamanda.$(LIB_EXTENSION) \
        @LEXLIB@ \
+       $(READLINE_LIBS) \
        ../client-src/libamclient.$(LIB_EXTENSION) \
        ../common-src/libamanda.$(LIB_EXTENSION) \
-       ../gnulib/libgnu.$(LIB_EXTENSION) \
-       $(READLINE_LIBS)
+       ../gnulib/libgnu.$(LIB_EXTENSION) 
 
 amrecover_CSRC =       amrecover.c                                     \
                        display_commands.c              extract_list.c  \
@@ -42,27 +44,18 @@ AM_YFLAGS =         -d
 
 # so that uscan.c is never generated before uparse.h
 # otherwise we might have makedepend problems
-$(srcdir)/uscan.c: $(srcdir)/uparse.h
+uscan.c: uparse.h
 
-uscan.$(OBJEXT): $(srcdir)/uscan.c
+# these two commands are specially defined to omit $(AMANDA_WARNING_CFLAGS)
+# since we don't want warnings for generated code
+uscan.$(OBJEXT): uscan.c
        $(CC) $(CFLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(CPPFLAGS) -c $<
 
-uparse.$(OBJEXT): $(srcdir)/uparse.c
+uparse.$(OBJEXT): uparse.c
        $(CC) $(CFLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(CPPFLAGS) -c $<
 
-
-install-exec-hook:
-       @list="$(sbin_PROGRAMS)"; \
-       for p in $$list; do \
-               pa=$(DESTDIR)$(sbindir)/`echo $$p|sed '$(transform)'`; \
-               echo chown $(BINARY_OWNER) $$pa; \
-               chown $(BINARY_OWNER) $$pa; \
-               echo chgrp $(SETUID_GROUP) $$pa; \
-               chgrp $(SETUID_GROUP) $$pa; \
-               echo chmod o-rwx $$pa; \
-               chmod o-rwx $$pa; \
-       done
-
+INSTALLPERMS_exec = \
+       dest=$(sbindir) chown=amanda chmod=o-rwx $(sbin_PROGRAMS)
 
 lint:
        @f="$(amrecover_CSRC)";                                                 \
@@ -71,7 +64,7 @@ lint:
        (cd ../server-src; make listlibsrc);                                    \
        f="$$f "`cat ../server-src/listlibsrc.output`;                          \
        echo $(LINT) $$f;                                                       \
-       $(LINT) $(LINTFLAGS) $(CPPFLAGS) $(DEFS) -I. -I../config $(INCLUDES) $$f;\
+       $(LINT) $(LINTFLAGS) $(CPPFLAGS) $(DEFS) -I. -I$(top_builddir)/config $(INCLUDES) $$f;\
        if [ $$? -ne 0 ]; then                                                  \
            exit 1;                                                             \
        fi;                                                                     \