Imported Upstream version 2.6.1
[debian/amanda] / man / Makefile.am
index c06034116a84722ffcb767645e6d6302481cee9a..2525dee74a8f6e56f445081fab0250746fb2be4d 100644 (file)
@@ -6,38 +6,53 @@ AMPLOT_MAN_PAGES =  amplot.8
 
 COMMON_MAN_PAGES =  amanda.8 \
                    amanda.conf.5 \
-                   amanda-client.conf.5
-
-SERVER_MAN_PAGES =  amadmin.8 \
-                   amcheck.8 \
-                   amcheckdb.8 \
-                   amcheckdump.8 \
-                   amcleanup.8 \
-                   amdd.8 \
-                   amdevcheck.8 \
-                   amdump.8 \
-                   amflush.8 \
-                   amgetconf.8 \
-                   amlabel.8 \
-                   ammt.8 \
-                   amoverview.8 \
-                   amreport.8 \
-                   amrmtape.8 \
-                   amstatus.8 \
-                   amtape.8 \
-                   amtapetype.8 \
-                   amtoc.8 \
-                   amverify.8 \
-                   amverifyrun.8 \
-                   amserverconfig.8 \
-                   amaddclient.8 \
-                   amcheckdump.8 \
-                   amcrypt.8 \
-                   amaespipe.8 \
-                   amgpgcrypt.8 \
-                   amcryptsimple.8  \
-                   amcrypt-ossl.8 \
-                   amcrypt-ossl-asym.8
+                   amanda-client.conf.5 \
+                   amanda-scripts.7 \
+                   amanda-archive-format.5 \
+                   amanda-auth.7 \
+                   amarchiver.8 \
+                   script-email.8
+
+CLIENT_MAN_PAGES = \
+    amanda-applications.7 \
+    amgtar.8 \
+    amsamba.8 \
+    amstar.8 \
+    amzfs-snapshot.8 \
+    amzfs-sendrecv.8
+
+SERVER_MAN_PAGES =  \
+    amanda-devices.7 \
+    amanda-changers.7 \
+    amaddclient.8    \
+    amadmin.8 \
+    amaespipe.8 \
+    amcheck.8 \
+    amcheckdb.8 \
+    amcheckdump.8 \
+    amcleanup.8 \
+    amcrypt-ossl-asym.8 \
+    amcrypt-ossl.8   \
+    amcrypt.8 \
+    amcryptsimple.8  \
+    amdevcheck.8 \
+    amdump.8 \
+    amflush.8 \
+    amgetconf.8 \
+    amgpgcrypt.8 \
+    amlabel.8 \
+    amoverview.8 \
+    amreport.8 \
+    amrmtape.8 \
+    amserverconfig.8 \
+    amservice.8 \
+    amstatus.8 \
+    amtape.8 \
+    amtapetype.8 \
+    amtoc.8 \
+    amvault.8 \
+    disklist.5 \
+    tapelist.5
 
 RECOVER_MAN_PAGES =  amrecover.8
 
@@ -45,7 +60,7 @@ RESTORE_MAN_PAGES =  amrestore.8 \
                     amfetchdump.8
 
 ALL_MAN_PAGES = $(AMPLOT_MAN_PAGES) \
-          $(COMMON_MAN_PAGES) \
+          $(CLIENT_MAN_PAGES) \
           $(COMMON_MAN_PAGES) \
           $(SERVER_MAN_PAGES) \
           $(RECOVER_MAN_PAGES) \
@@ -55,6 +70,9 @@ WANTED_MAN_PAGES = $(COMMON_MAN_PAGES)
 if WANT_AMPLOT
   WANTED_MAN_PAGES += $(AMPLOT_MAN_PAGES)
 endif
+if WANT_CLIENT
+  WANTED_MAN_PAGES += $(CLIENT_MAN_PAGES)
+endif
 if WANT_SERVER
   WANTED_MAN_PAGES += $(SERVER_MAN_PAGES)
 endif
@@ -73,7 +91,7 @@ EXTRA_XML = xslt/expand-sambadoc.xsl \
             xslt/man.xsl.in \
             xslt/html.xsl.in \
             xslt/settings.xsl \
-           entities/global.entities \
+           entities/global.entities.in \
            entities/xinclude.dtd
 
 EXTRA_DIST = $(ALL_MAN_PAGES) $(MAN_XML) $(EXTRA_HTML) $(EXTRA_XML)
@@ -86,17 +104,22 @@ MAINTAINERCLEANFILES = $(ALL_MAN_PAGES)
 # some of the XSL needs to know what docbook-xsl version we've selected
 %.xsl: %.xsl.in $(top_builddir)/config.status
        $(top_builddir)/config.status --file=$@:$<
+       rm -f config.log
+
+entities/global.entities: entities/global.entities.in $(top_builddir)/config.status
+       $(top_builddir)/config.status --file=$@:$<
+       rm -f config.log
 
 if   ENABLE_MANPAGE_BUILD
 # phase one of the documentation build expands some macros.
-xml-source/%.proc.xml: $(SRCMANPAGEDIR)/%.xml $(srcdir)/xslt/expand-sambadoc.xsl
+xml-source/%.proc.xml: $(SRCMANPAGEDIR)/%.xml $(srcdir)/xslt/expand-sambadoc.xsl entities/global.entities
        $(XSLTPROC) $(XSLTPROC_FLAGS) --path $(srcdir)/xslt/ --xinclude --stringparam latex.imagebasedir "$*/" --stringparam noreference 1 --output $@ $(srcdir)/xslt/expand-sambadoc.xsl $<
 
 # phase two generates a manpage from the resulting "expanded" docbook XML
-%: xml-source/%.proc.xml $(srcdir)/xslt/man.xsl
+%: xml-source/%.proc.xml $(srcdir)/xslt/man.xsl entities/global.entities
        $(XSLTPROC) $(XSLTPROC_FLAGS) --path $(srcdir)/xslt/ --output $@ xslt/man.xsl $<
 
-%.html: xml-source/%.proc.xml $(srcdir)/xslt/html.xsl
+%.html: xml-source/%.proc.xml $(srcdir)/xslt/html.xsl entities/global.entities
        $(XSLTPROC) $(XSLTPROC_FLAGS) --path $(srcdir)/xslt/ --output $@ xslt/html.xsl $<
 
 else   !ENABLE_MANPAGE_BUILD