Merge commit 'upstream/3.1.0'
[debian/amanda] / gnulib / regenerate / regenerate
index a32ab348b93e2dede03fa7401213099f9a5cef06..6f42fa014782941304af48ccf11826cd02349de5 100644 (file)
@@ -1,7 +1,10 @@
 #! /bin/bash
 
-# Gnulib files in zmanda repo are from gnulib CVS updated with:
-#   cvs update -D '2007-10-25 17:00:00 -0600'
+# Gnulib files in zmanda repo are from gnulib GIT.  To check out the
+# same version as was used to generate the source in the repository,
+# run the following in your git repository:
+#
+#   git checkout 8d2524ce78ca107074727cbd8780c26a203a107c
 
 # get to the project root
 cd `dirname $0`/../..
@@ -36,7 +39,9 @@ shopt -u nullglob
 ## Add your modules here, then see below if you need to patch them. ##
 ######################################################################
 
-GNULIB_MODULES="getaddrinfo lock visibility base64 physmem fsusage mkdtemp"
+GNULIB_MODULES="getaddrinfo lock visibility base64 physmem fsusage"
+GNULIB_MODULES="$GNULIB_MODULES mkdtemp getopt full-read full-write"
+GNULIB_MODULES="$GNULIB_MODULES lseek ftruncate fseeko ftello regex"
 
 ######################################################################
 ## End modules                                                      ##
@@ -58,19 +63,19 @@ PATCH_DIR="`pwd`/gnulib/regenerate"
 
 # Patch Makefile.am to not error out on warnings
 patch -p0 < "${PATCH_DIR}/no-error.patch" || exit 1
-
-
-# Add John's patches to getaddrinfo.c for use in cygwin
-patch -p0 < "${PATCH_DIR}/getaddrinfo-cygwin.patch" || exit 1
-
+rm -f gnulib/Makefile.am.orig
 
 # Add info to the makefile to ensure all this stuff gets put in
 # the distribution tarball
 (   echo ""
     echo "# Make sure regenerate/* are in the distribution tarball"
-    echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print `
+    echo "EXTRA_DIST += "`cd gnulib; find regenerate -name .svn -prune -o -type f -print | sort`
 ) >> gnulib/Makefile.am
 
+# remove .gitignore files, which ignore things we would like to see
+rm -f config/gnulib/.gitignore
+rm -f gnulib/.gitignore
+
 ######################################################################
 ## End patches                                                      ##
 ######################################################################