Imported Upstream version 3.3.3
[debian/amanda] / example / Makefile.in
index 9827d7a8e1bc16a885f35c87a352d4b40648f47d..8911277669e8ac68e1b8c5f057a08e2ae5e9dcc8 100644 (file)
@@ -1,9 +1,9 @@
-# Makefile.in generated by automake 1.11.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.6 from Makefile.am.
 # @configure_input@
 
 # Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008, 2009  Free Software Foundation,
-# Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
 # This Makefile.in is free software; the Free Software Foundation
 # gives unlimited permission to copy and/or distribute it,
 # with or without modifications, as long as this notice is preserved.
 # vim:ft=automake
 # Copyright (c) 2007-2012 Zmanda, Inc.  All Rights Reserved.
 #
-# This program is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License version 2 as published
-# by the Free Software Foundation.
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
 #
 # This program is distributed in the hope that it will be useful, but
 # WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
 # in this file at all, due to limitations of Automake.
 
 VPATH = @srcdir@
+am__make_dryrun = \
+  { \
+    am__dry=no; \
+    case $$MAKEFLAGS in \
+      *\\[\ \  ]*) \
+        echo 'am--echo: ; @echo "AM"  OK' | $(MAKE) -f - 2>/dev/null \
+          | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+      *) \
+        for am__flg in $$MAKEFLAGS; do \
+          case $$am__flg in \
+            *=*|--*) ;; \
+            *n*) am__dry=yes; break;; \
+          esac; \
+        done;; \
+    esac; \
+    test $$am__dry = yes; \
+  }
 pkgdatadir = $(datadir)/@PACKAGE@
 pkgincludedir = $(includedir)/@PACKAGE@
 pkglibdir = $(libdir)/@PACKAGE@
@@ -271,6 +289,11 @@ CONFIG_CLEAN_FILES =
 CONFIG_CLEAN_VPATH_FILES =
 SOURCES =
 DIST_SOURCES =
+am__can_run_installinfo = \
+  case $$AM_UPDATE_INFO_DIR in \
+    n|no|NO) false;; \
+    *) (install-info --version) >/dev/null 2>&1;; \
+  esac
 am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
 am__vpath_adj = case $$p in \
     $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
@@ -292,6 +315,12 @@ am__nobase_list = $(am__nobase_strip_setup); \
 am__base_list = \
   sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
   sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+am__uninstall_files_from_dir = { \
+  test -z "$$files" \
+    || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+    || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+         $(am__cd) "$$dir" && rm -f $$files; }; \
+  }
 am__installdirs = "$(DESTDIR)$(client_exampledir)" \
        "$(DESTDIR)$(lbltempldir)" "$(DESTDIR)$(server_exampledir)" \
        "$(DESTDIR)$(templatedir)"
@@ -1228,6 +1257,7 @@ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
            echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
            cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
        esac;
+$(top_srcdir)/config/automake/vars.am $(top_srcdir)/config/automake/installperms.am:
 
 $(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
        cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
@@ -1245,8 +1275,11 @@ clean-libtool:
        -rm -rf .libs _libs
 install-client_exampleDATA: $(client_example_DATA)
        @$(NORMAL_INSTALL)
-       test -z "$(client_exampledir)" || $(MKDIR_P) "$(DESTDIR)$(client_exampledir)"
        @list='$(client_example_DATA)'; test -n "$(client_exampledir)" || list=; \
+       if test -n "$$list"; then \
+         echo " $(MKDIR_P) '$(DESTDIR)$(client_exampledir)'"; \
+         $(MKDIR_P) "$(DESTDIR)$(client_exampledir)" || exit 1; \
+       fi; \
        for p in $$list; do \
          if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
          echo "$$d$$p"; \
@@ -1260,13 +1293,14 @@ uninstall-client_exampleDATA:
        @$(NORMAL_UNINSTALL)
        @list='$(client_example_DATA)'; test -n "$(client_exampledir)" || list=; \
        files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
-       test -n "$$files" || exit 0; \
-       echo " ( cd '$(DESTDIR)$(client_exampledir)' && rm -f" $$files ")"; \
-       cd "$(DESTDIR)$(client_exampledir)" && rm -f $$files
+       dir='$(DESTDIR)$(client_exampledir)'; $(am__uninstall_files_from_dir)
 install-lbltemplDATA: $(lbltempl_DATA)
        @$(NORMAL_INSTALL)
-       test -z "$(lbltempldir)" || $(MKDIR_P) "$(DESTDIR)$(lbltempldir)"
        @list='$(lbltempl_DATA)'; test -n "$(lbltempldir)" || list=; \
+       if test -n "$$list"; then \
+         echo " $(MKDIR_P) '$(DESTDIR)$(lbltempldir)'"; \
+         $(MKDIR_P) "$(DESTDIR)$(lbltempldir)" || exit 1; \
+       fi; \
        for p in $$list; do \
          if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
          echo "$$d$$p"; \
@@ -1280,13 +1314,14 @@ uninstall-lbltemplDATA:
        @$(NORMAL_UNINSTALL)
        @list='$(lbltempl_DATA)'; test -n "$(lbltempldir)" || list=; \
        files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
-       test -n "$$files" || exit 0; \
-       echo " ( cd '$(DESTDIR)$(lbltempldir)' && rm -f" $$files ")"; \
-       cd "$(DESTDIR)$(lbltempldir)" && rm -f $$files
+       dir='$(DESTDIR)$(lbltempldir)'; $(am__uninstall_files_from_dir)
 install-server_exampleDATA: $(server_example_DATA)
        @$(NORMAL_INSTALL)
-       test -z "$(server_exampledir)" || $(MKDIR_P) "$(DESTDIR)$(server_exampledir)"
        @list='$(server_example_DATA)'; test -n "$(server_exampledir)" || list=; \
+       if test -n "$$list"; then \
+         echo " $(MKDIR_P) '$(DESTDIR)$(server_exampledir)'"; \
+         $(MKDIR_P) "$(DESTDIR)$(server_exampledir)" || exit 1; \
+       fi; \
        for p in $$list; do \
          if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
          echo "$$d$$p"; \
@@ -1300,13 +1335,14 @@ uninstall-server_exampleDATA:
        @$(NORMAL_UNINSTALL)
        @list='$(server_example_DATA)'; test -n "$(server_exampledir)" || list=; \
        files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
-       test -n "$$files" || exit 0; \
-       echo " ( cd '$(DESTDIR)$(server_exampledir)' && rm -f" $$files ")"; \
-       cd "$(DESTDIR)$(server_exampledir)" && rm -f $$files
+       dir='$(DESTDIR)$(server_exampledir)'; $(am__uninstall_files_from_dir)
 install-templateDATA: $(template_DATA)
        @$(NORMAL_INSTALL)
-       test -z "$(templatedir)" || $(MKDIR_P) "$(DESTDIR)$(templatedir)"
        @list='$(template_DATA)'; test -n "$(templatedir)" || list=; \
+       if test -n "$$list"; then \
+         echo " $(MKDIR_P) '$(DESTDIR)$(templatedir)'"; \
+         $(MKDIR_P) "$(DESTDIR)$(templatedir)" || exit 1; \
+       fi; \
        for p in $$list; do \
          if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
          echo "$$d$$p"; \
@@ -1320,9 +1356,7 @@ uninstall-templateDATA:
        @$(NORMAL_UNINSTALL)
        @list='$(template_DATA)'; test -n "$(templatedir)" || list=; \
        files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
-       test -n "$$files" || exit 0; \
-       echo " ( cd '$(DESTDIR)$(templatedir)' && rm -f" $$files ")"; \
-       cd "$(DESTDIR)$(templatedir)" && rm -f $$files
+       dir='$(DESTDIR)$(templatedir)'; $(am__uninstall_files_from_dir)
 tags: TAGS
 TAGS:
 
@@ -1379,10 +1413,15 @@ install-am: all-am
 
 installcheck: installcheck-am
 install-strip:
-       $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
-         install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
-         `test -z '$(STRIP)' || \
-           echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+       if test -z '$(STRIP)'; then \
+         $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+           install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+             install; \
+       else \
+         $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+           install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+           "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'" install; \
+       fi
 mostlyclean-generic:
        -test -z "$(MOSTLYCLEANFILES)" || rm -f $(MOSTLYCLEANFILES)