Imported Upstream version 2.6.0
[debian/amanda] / example / Makefile.am
index e22862bac033dfea481160d1471ae078a4a874e2..824aead04655caa0ad704e9ab8383fcdd563761e 100644 (file)
@@ -1,10 +1,43 @@
 # Makefile for sample configuration files
 
-noinst_DATA = amanda.conf \
-               amanda-client.conf
+include $(top_srcdir)/config/automake/installperms.am
 
-EXTRA_DIST =   chg-multi.conf chg-scsi.conf config.site disklist \
-               DLT.ps EXB-8500.ps HP-DAT.ps 8.5x11.ps 3hole.ps DIN-A4.ps \
+amanda_dir     = $(localstatedir)/lib/amanda
+templatedir   = $(amanda_dir)/template.d
+exampledir    = $(amanda_dir)/example
+lbltempldir   = $(amanda_dir)/example/label-templates
+
+EXTRA_DIST =   chg-multi.conf \
+               chg-scsi.conf \
+               config.site \
+               disklist \
                chg-mcutil.conf
 
+dist_template_DATA = template.d/advanced.conf \
+               template.d/amanda-harddisk.conf \
+               template.d/amanda-single-tape.conf \
+               template.d/amanda-tape-changer.conf \
+               template.d/amanda-S3.conf \
+               template.d/dumptypes \
+               template.d/tapetypes \
+               template.d/README   \
+               template.d/chg-manual.conf   
+
+dist_example_DATA = amanda.conf \
+              amanda-client.conf \
+              inetd.conf.amandaclient \
+              xinetd.amandaclient \
+              xinetd.amandaserver 
+
+dist_lbltempl_DATA = DLT.ps \
+                EXB-8500.ps \
+                HP-DAT.ps \
+                8.5x11.ps \
+                3hole.ps \
+               DLT-A4.ps \
+                DIN-A4.ps 
 
+INSTALLPERMS_data = chown=amanda \
+       dest=$(templatedir) $(dist_template_DATA) \
+       dest=$(exampledir) $(dist_example_DATA) \
+       dest=$(libtempldir) $(dist_libtempl_DATA)