Imported Upstream version 3.1.0
[debian/amanda] / device-src / Makefile.am
index 41c5b23d88d06af184a8151a62645e71afd3840a..a73fc624cce0b363ceb1b420f8b3484826579e58 100644 (file)
@@ -6,24 +6,45 @@ include $(top_srcdir)/config/automake/precompile.am
 
 INCLUDES =     -I$(top_builddir)/common-src \
                -I$(top_srcdir)/common-src \
+               -I$(top_srcdir)/xfer-src \
+               -I$(top_srcdir)/ndmp-src \
                -I$(top_srcdir)/gnulib
 
 AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
+if GCC_COMPILER
+# ndmp-device.c includes files with old-skool prototypes, so:
+AM_CFLAGS += -Wno-strict-prototypes
+endif
 AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
 
 sbin_PROGRAMS =
 
-CHECK_PERL = amtapetype
-SCRIPTS_PERL = $(CHECK_PERL)
+SCRIPTS_PERL = \
+       amdevcheck \
+       amtapetype
 sbin_SCRIPTS = $(SCRIPTS_PERL)
 
 ## libamdevice.la
 
 amlib_LTLIBRARIES =    libamdevice.la
 libamdevice_la_LDFLAGS = -release $(VERSION) 
-libamdevice_la_SOURCES = property.c device.c device-queueing.c \
-       null-device.c rait-device.c vfs-device.c 
-libamdevice_la_LIBADD = ../common-src/libamanda.la
+libamdevice_la_SOURCES = \
+       property.c \
+       device.c \
+       device-queueing.c \
+       directtcp-connection.c \
+       null-device.c \
+       rait-device.c \
+       vfs-device.c \
+       xfer-source-device.c \
+       xfer-dest-device.c \
+       xfer-dest-taper.c \
+       xfer-dest-taper-splitter.c \
+       xfer-dest-taper-directtcp.c \
+       xfer-source-recovery.c
+libamdevice_la_LIBADD = \
+       ../common-src/libamanda.la \
+       ../xfer-src/libamxfer.la
 
 # tape-device has *lots* of conditionals; the first is whether to support
 # the device at all, and the remainder select a particular kind of OS-specific
@@ -51,6 +72,15 @@ if WANT_S3_DEVICE
 libamdevice_la_SOURCES += s3-device.c s3.c s3-util.c
 endif
 
+if WANT_DVDRW_DEVICE
+libamdevice_la_SOURCES += dvdrw-device.c
+endif
+
+if WANT_NDMP_DEVICE
+libamdevice_la_SOURCES += ndmp-device.c
+libamdevice_la_LIBADD += ../ndmp-src/libndmlib.la
+endif
+
 ## automake-style tests
 
 TESTS = vfs-test
@@ -73,10 +103,13 @@ endif
 noinst_HEADERS = \
        device-queueing.h \
        device.h \
+       directtcp-connection.h \
        property.h \
        s3.h \
        s3-util.h \
        tape-device.h \
-       tape-ops.h
-       
+       tape-ops.h \
+       xfer-device.h \
+       vfs-device.h
+
 aminclude_HEADERS =