symlink to upstream's installation of examples in /usr/share/amanda,
[debian/amanda] / debian / rules
index a26fcc19bcbfd7166ebe54e975130e5c9170e01a..4fc39bcbd18d21acb33f378d6240db887c176b2b 100755 (executable)
@@ -1,9 +1,7 @@
 #!/usr/bin/make -f
-# debian/rules for amanda using debhelper
-# Copyright 1998-2009 by Bdale Garbee.  License GPL v2
+# Copyright 1998-2011 by Bdale Garbee.  License GPL v2
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 r=$(shell pwd)/debian/amanda-common
 s=$(shell pwd)/debian/amanda-server
@@ -42,22 +40,20 @@ configure-stamp:
                --with-ssh-security \
                --with-bsdtcp-security \
                --with-bsdudp-security \
-               --without-ipv6
+               --without-ipv6 \
+               --enable-s3-device
 
        touch missing
        touch configure-stamp
 
-build: build-stamp 
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp: configure-stamp
        dh_testdir
        MAILER=/usr/bin/mail $(MAKE) CFLAGS="-O2 -g -Wall \
                -DAMANDATES_FILE='\"/var/lib/amanda/amandates\"' \
                -DIGNORE_TAR_ERRORS "
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
-       $(MAKE) check
-endif
-endif
        touch build-stamp
 
 clean:
@@ -82,13 +78,12 @@ binary-arch: build
        dh_clean -k
        dh_installdirs -a
        make install DESTDIR=$(r)
+       sed -i "/dependency_libs/ s/'.*'/''/" `find $(r)/usr/lib/amanda/ -name '*.la'`
        install -m 644 debian/amandahosts $(r)/etc/amandahosts
        dh_installdocs -a
-       dh_installexamples -a
+       ln -s /usr/share/amanda/example $(r)/usr/share/doc/examples
        cp ChangeLog $(r)/usr/share/doc/amanda-common/changelog
-       cp debian/xinetd.d/amandaidx $(s)/etc/xinetd.d
-       cp debian/xinetd.d/amidxtape $(s)/etc/xinetd.d
-       cp debian/xinetd.d/amanda $(r)/etc/xinetd.d                     
+       cp example/xinetd.amandaserver $(r)/etc/xinetd.d/amanda
        dh_installmenu -a
        dh_installcron -a
        dh_installchangelogs -a
@@ -97,7 +92,6 @@ binary-arch: build
        dh_compress -a
        dh_movefiles -a --sourcedir=debian/amanda-common
        rm -r $(r)/usr/share/amanda
-       rm $(s)/usr/lib/amanda/chg-mtx
        dh_fixperms -av
        # fix perms manually
        chown -R backup:backup debian/*/var/lib/*
@@ -131,13 +125,13 @@ binary-arch: build
                $(s)/usr/sbin/amcheck
        install -o root -g root -m 0644 debian/amanda-client.lintian \
                $(c)/usr/share/lintian/overrides/amanda-client
-#      install -o root -g root -m 0644 debian/amanda-common.lintian \
-#              $(r)/usr/share/lintian/overrides/amanda-common
+       install -o root -g root -m 0644 debian/amanda-common.lintian \
+               $(r)/usr/share/lintian/overrides/amanda-common
        install -o root -g root -m 0644 debian/amanda-server.lintian \
                $(s)/usr/share/lintian/overrides/amanda-server
        dh_makeshlibs -pamanda-common --noscripts
        dh_installdeb -a
-       dh_perl -a
+       dh_perl -a usr/lib/amanda/perl
        dh_shlibdeps -a -l"debian/amanda-common/usr/lib:debian/amanda-client/usr/lib:debian/amanda-server/usr/lib"
        # strip out the non-versioned amanda-common references, we need
        # the versioned ones in the control file and dupes are ugly...
@@ -153,4 +147,4 @@ source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: configure build-indep build-arch build clean binary-indep binary-arch binary