enable support for Amazon S3 storage on request from Christopher McCrory
[debian/amanda] / debian / rules
index 48124a7ae3d510e4fd3be0ceeb5d9ef28587780b..026b6ef53ff832982fb7e57931f0dba7b3b22e37 100755 (executable)
@@ -42,7 +42,8 @@ configure-stamp:
                --with-ssh-security \
                --with-bsdtcp-security \
                --with-bsdudp-security \
-               --without-ipv6
+               --without-ipv6 \
+               --enable-s3-device
 
        touch missing
        touch configure-stamp
@@ -50,7 +51,7 @@ configure-stamp:
 build: build-stamp 
 build-stamp: configure-stamp
        dh_testdir
-       MAILER=/usr/bin/mail make CFLAGS="-O2 -g -Wall \
+       MAILER=/usr/bin/mail $(MAKE) CFLAGS="-O2 -g -Wall \
                -DAMANDATES_FILE='\"/var/lib/amanda/amandates\"' \
                -DIGNORE_TAR_ERRORS "
        touch build-stamp
@@ -91,7 +92,7 @@ binary-arch: build
        dh_strip -a
        dh_compress -a
        dh_movefiles -a --sourcedir=debian/amanda-common
-       rm $(s)/usr/lib/amanda/chg-mtx
+       rm -r $(r)/usr/share/amanda
        dh_fixperms -av
        # fix perms manually
        chown -R backup:backup debian/*/var/lib/*
@@ -104,6 +105,9 @@ binary-arch: build
        chmod -R u=rwX,g=rwX,o-rwx $(c)/var/lib/amanda/gnutar-lists
        # .. setuid
        chown root:backup \
+               $(c)/usr/lib/amanda/application/amgtar \
+               $(c)/usr/lib/amanda/application/amstar \
+               $(c)/usr/lib/amanda/calcsize \
                $(c)/usr/lib/amanda/killpgrp \
                $(c)/usr/lib/amanda/rundump \
                $(c)/usr/lib/amanda/runtar \
@@ -111,6 +115,9 @@ binary-arch: build
                $(s)/usr/lib/amanda/planner \
                $(s)/usr/sbin/amcheck
        chmod u=srwx,g=rx,o=r \
+               $(c)/usr/lib/amanda/application/amgtar \
+               $(c)/usr/lib/amanda/application/amstar \
+               $(c)/usr/lib/amanda/calcsize \
                $(c)/usr/lib/amanda/killpgrp \
                $(c)/usr/lib/amanda/rundump \
                $(c)/usr/lib/amanda/runtar \
@@ -119,12 +126,13 @@ binary-arch: build
                $(s)/usr/sbin/amcheck
        install -o root -g root -m 0644 debian/amanda-client.lintian \
                $(c)/usr/share/lintian/overrides/amanda-client
-       install -o root -g root -m 0644 debian/amanda-common.lintian \
-               $(r)/usr/share/lintian/overrides/amanda-common
+#      install -o root -g root -m 0644 debian/amanda-common.lintian \
+#              $(r)/usr/share/lintian/overrides/amanda-common
        install -o root -g root -m 0644 debian/amanda-server.lintian \
                $(s)/usr/share/lintian/overrides/amanda-server
-       dh_makeshlibs -pamanda-common
+       dh_makeshlibs -pamanda-common --noscripts
        dh_installdeb -a
+       dh_perl -a
        dh_shlibdeps -a -l"debian/amanda-common/usr/lib:debian/amanda-client/usr/lib:debian/amanda-server/usr/lib"
        # strip out the non-versioned amanda-common references, we need
        # the versioned ones in the control file and dupes are ugly...