Imported Upstream version 2.5.0
[debian/amanda] / contrib / sst / Makefile
index 53bf09e2485af982ff56302afb686b5936fa8670..b53a9551af1109ae0f2edb18a05688af49c99a70 100644 (file)
@@ -1,16 +1,31 @@
-all: sst sstest
 
-sst: sst.c
-       $(CC) -D_KERNEL -c sst.c
-       ld -r sst.o -o sst
+#
+# Copyright (c) 1996,1997, by Sun Microsystems, Inc.
+# All Rights Reserved
+#
+#ident "@(#)Makefile   1.9     97/09/14 SMI"
+#
+
+TOP= ..
+
+include $(TOP)/Makefile.master
+
+.KEEP_STATE:
+
+MOD=sst
+
+OBJS=  sst.o
+
+MOD_CONF= $(MOD:%=%.conf)
+
+all: $(MOD)
+
+include ../Makefile.driver
+
+CFLAGS += -D$(INST) $(ENVCPPFLAGS1) $(ENVCPPFLAGS2) -DDEBUG
 
 sstest: sstest.c
-       $(CC) -o sstest sstest.c
+       $(CC) -o $(INST)/sstest $(ENVCPPFLAGS1) $(ENVCPPFLAGS2) sstest.c
 
-install: sst
-       cp sst /usr/kernel/drv
-       cp sst.conf /usr/kernel/drv
-#      echo "type=sample_driver;name=sst;minor=character\trsst\A1" >> /etc/devlink.tab
 
-clean:
-       rm sst sstest
+DDICTFLAGS += -D_USCSI