lintian doesn't like orphan packages with uploaders...
[debian/amanda] / configure.in
index 9755ffd4fbefc377f5e8658912b3d0b90bdf7bd1..72c255df98cadc05cb057b57d6f49185915c1361 100644 (file)
@@ -1,16 +1,19 @@
-AC_INIT
+AMANDA_INIT_VERSION
+AC_INIT([amanda], [AMANDA_F_VERSION])
 AC_CONFIG_SRCDIR([common-src/amanda.h])
 AC_CONFIG_AUX_DIR(config)
-AC_CANONICAL_TARGET([])
+AC_CONFIG_MACRO_DIR(config)
+AC_CANONICAL_HOST
 
 PACKAGE=amanda
 AC_SUBST(PACKAGE)
 
-AM_INIT_AUTOMAKE(amanda, "2.6.1p2")
+AMANDA_VERSION
+AM_INIT_AUTOMAKE(tar-ustar 1.10)
 AC_CONFIG_HEADERS([config/config.h])
 
 dnl Minimum Autoconf version required.
-AC_PREREQ(2.59)
+AC_PREREQ(2.64)
 
 #
 # Take care of some early Amanda-specific setup
@@ -32,6 +35,7 @@ AC_OBJEXT
 AC_EXEEXT
 AMANDA_INIT_FLAGS
 AMANDA_ADD_CPPFLAGS([-D_GNU_SOURCE])
+AMANDA_AS_NEEDED
 
 dnl -------------------------------------------------------------------------
 
@@ -62,6 +66,7 @@ AMANDA_WITH_DEBUG_DAYS
 AMANDA_WITH_TESTING
 AMANDA_WITH_SINGLE_USERID
 AMANDA_DISABLE_INSTALLPERMS
+AMANDA_DISABLE_SYNTAX_CHECKS
 
 dnl -------------------------------------------------------------------------
 
@@ -73,13 +78,11 @@ AMANDA_SETUP_AMPLOT
 AMANDA_SETUP_DOCUMENTATION
 AMANDA_SETUP_DEFAULTS
 AMANDA_SETUP_LFS
-AMANDA_SETUP_CHANGER
 AMANDA_SETUP_GETFSENT
 AMANDA_SETUP_FILE_LOCKING
 AMANDA_SETUP_SWIG
 AMANDA_CHECK_COMPRESSION
 AMANDA_CHECK_IPV6
-AMANDA_CHECK_SHMEM
 AMANDA_CHECK_READDIR
 AMANDA_CHECK_DEVICE_PREFIXES
 AMANDA_SYSHACKS
@@ -93,12 +96,6 @@ dnl These lines *must* be in configure.in, and not indented
 AM_GNU_GETTEXT_VERSION([0.15])
 AM_GNU_GETTEXT([external])
 
-#
-# Devices
-#
-AMANDA_S3_DEVICE
-AMANDA_TAPE_DEVICE
-
 #
 # Security (authentication) mechansims
 #
@@ -107,7 +104,6 @@ AMANDA_BSDTCP_SECURITY
 AMANDA_BSDUDP_SECURITY
 AMANDA_RSH_SECURITY
 AMANDA_SSH_SECURITY
-AMANDA_KRB4_SECURITY
 AMANDA_KRB5_SECURITY
 
 #
@@ -118,6 +114,8 @@ AMANDA_PROG_VXDUMP_VXRESTORE
 AMANDA_PROG_VDUMP_VRESTORE
 AMANDA_PROG_DUMP_RESTORE
 AMANDA_PROG_GNUTAR
+AMANDA_PROG_STAR
+AMANDA_PROG_SUNTAR
 AMANDA_PROG_SAMBA_CLIENT
 AMANDA_CHECK_USE_RUNDUMP
 
@@ -127,7 +125,7 @@ AMANDA_CHECK_USE_RUNDUMP
 AMANDA_PROG_GREP
 AC_PROG_EGREP
 AMANDA_PROG_LINT
-AM_PROG_LEX
+AMANDA_PROG_LEX
 AMANDA_PROG_AR
 AMANDA_PROG_GETTEXT
 AC_PROG_AWK
@@ -138,11 +136,17 @@ AMANDA_PROG_BASH
 AMANDA_PROG_SORT
 AMANDA_PROG_MAILER
 AMANDA_PROG_MT
-AMANDA_PROG_PRINT
+AMANDA_PROG_MTX
+AMANDA_PROG_MOUNT
+AMANDA_PROG_UMOUNT
+AMANDA_PROG_UNAME
+AMANDA_PROG_LPR
 AMANDA_PROG_PCAT
 AMANDA_PROG_PERL
 AMANDA_PROG_SWIG
 AMANDA_PS_ARGUMENT
+AMANDA_PROG_RPCGEN
+AMANDA_PROG_NC
 
 dnl -------------------------------------------------------------------------
 
@@ -175,7 +179,8 @@ AMANDA_ENABLE_GCC_WARNING([float-equal])
 AMANDA_ENABLE_GCC_WARNING([old-style-definition])
 AMANDA_DISABLE_GCC_WARNING([strict-aliasing])
 AMANDA_DISABLE_GCC_WARNING([unknown-pragmas])
-
+AMANDA_WERROR_FLAGS
+AMANDA_SWIG_ERROR
 
 #
 # Libtool
@@ -191,18 +196,17 @@ AC_HEADER_DIRENT
 AC_HEADER_STDC
 AC_HEADER_TIME
 AC_CHECK_HEADERS(
-       arpa/inet.h \
        grp.h \
        libc.h \
        libgen.h \
        limits.h \
        math.h \
-       netdb.h \
        netinet/in.h \
        regex.h \
        stdarg.h \
        stdlib.h \
        strings.h \
+       rpc/rpc.h \
        sys/file.h \
        sys/ioctl.h \
        sys/ipc.h \
@@ -350,12 +354,21 @@ ICE_CHECK_DECL(time,time.h sys/time.h)
 ICE_CHECK_DECL(tolower,ctype.h)
 ICE_CHECK_DECL(toupper,ctype.h)
 ICE_CHECK_DECL(ungetc,stdio.h)
+AC_CHECK_FUNCS(unsetenv)
 ICE_CHECK_DECL(vfprintf,stdio.h stdlib.h)
 ICE_CHECK_DECL(vprintf,stdio.h stdlib.h)
 AC_CHECK_FUNC(wait4)
 ICE_CHECK_DECL(writev, unistd.h sys/uio.h)
 ICE_CHECK_DECL(strcasecmp,string.h strings.h)
 
+#
+# Devices
+#
+AMANDA_S3_DEVICE
+AMANDA_TAPE_DEVICE
+AMANDA_DVDRW_DEVICE
+AMANDA_NDMP_DEVICE
+
 dnl -------------------------------------------------------------------------
 
 dnl
@@ -370,36 +383,23 @@ AC_CONFIG_FILES([
     changer-src/Makefile
     client-src/Makefile
     common-src/Makefile
-    common-src/versuff.c
     config/Makefile
     device-src/Makefile
     application-src/Makefile
     example/Makefile
-    example/amanda-client.conf
-    example/amanda.conf
-    example/xinetd.amandaclient
-    example/xinetd.amandaserver
-    example/inetd.conf.amandaclient
-    example/inetd.conf.amandaserver
-    example/chg-mcutil.conf
-    example/template.d/advanced.conf
-    example/template.d/amanda-S3.conf
-    example/template.d/amanda-harddisk.conf
-    example/template.d/amanda-single-tape.conf
-    example/template.d/amanda-tape-changer.conf
     gnulib/Makefile
     installcheck/Makefile
     man/Makefile
+    ndmp-src/Makefile
     oldrecover-src/Makefile
     packaging/Makefile
+    perl/amglue/Makefile
     perl/Makefile
     po/Makefile
     recover-src/Makefile
-    restore-src/Makefile
     server-src/Makefile
     xfer-src/Makefile
 ])
 
 AC_OUTPUT
-AMANDA_GET_SVN_INFO
 AMANDA_SHOW_SUMMARY