Imported Upstream version 2.6.1
[debian/amanda] / configure.in
index b5eee29592b7b48329893e1e17dcccc0331a1156..338abfed355b3f6bc9ab23063a48a50b08eb5e05 100644 (file)
@@ -6,7 +6,7 @@ AC_CANONICAL_TARGET([])
 PACKAGE=amanda
 AC_SUBST(PACKAGE)
 
-AM_INIT_AUTOMAKE(amanda, "2.6.0p2")
+AM_INIT_AUTOMAKE(amanda, "2.6.1")
 AC_CONFIG_HEADERS([config/config.h])
 
 dnl Minimum Autoconf version required.
@@ -41,7 +41,7 @@ dnl -------------------------------------------------------------------------
 
 AMANDA_WITH_USER
 AMANDA_WITH_GROUP
-AMANDA_WITH_DUMPERDIR
+AMANDA_WITH_APPLICATIONDIR
 AMANDA_WITH_CONFIGDIR
 AMANDA_WITH_INDEXDIR
 AMANDA_WITH_DBDIR
@@ -142,6 +142,7 @@ AMANDA_PROG_PRINT
 AMANDA_PROG_PCAT
 AMANDA_PROG_PERL
 AMANDA_PROG_SWIG
+AMANDA_PS_ARGUMENT
 
 dnl -------------------------------------------------------------------------
 
@@ -168,6 +169,7 @@ AMANDA_ENABLE_GCC_WARNING([missing-prototypes])
 AMANDA_ENABLE_GCC_WARNING([strict-prototypes])
 AMANDA_ENABLE_GCC_WARNING([missing-declarations])
 AMANDA_ENABLE_GCC_WARNING([format])
+AMANDA_ENABLE_GCC_WARNING([format-security])
 AMANDA_ENABLE_GCC_WARNING([sign-compare])
 AMANDA_ENABLE_GCC_WARNING([float-equal])
 AMANDA_ENABLE_GCC_WARNING([old-style-definition])
@@ -185,6 +187,7 @@ AMANDA_STATIC_FLAGS
 #
 # headers
 #
+AC_HEADER_DIRENT
 AC_HEADER_STDC
 AC_HEADER_TIME
 AC_CHECK_HEADERS(
@@ -196,9 +199,9 @@ AC_CHECK_HEADERS(
        math.h \
        netdb.h \
        netinet/in.h \
+       regex.h \
        stdarg.h \
        stdlib.h \
-       string.h \
        strings.h \
        sys/file.h \
        sys/ioctl.h \
@@ -212,13 +215,17 @@ AC_CHECK_HEADERS(
        sys/types.h \
        sys/uio.h \
        syslog.h \
+       time.h \
        unistd.h \
 )
+AC_DEFINE([HAVE_AMANDA_H], 1, [Define to 1 if you have the "amanda.h" header file.])
+AC_DEFINE([HAVE_UTIL_H], 1, [Define to 1 if you have the "util.h" header file.])
+
+AC_DEFINE([USE_GETTEXT], 1, [Define to 1 if files will be processed with gettextize])
 
 #
 # Types
 #
-AC_SOCKADDR_STORAGE
 AC_CHECK_SIZEOF(int)
 AC_CHECK_SIZEOF(long)
 AC_CHECK_SIZEOF(long long)
@@ -323,7 +330,6 @@ ICE_CHECK_DECL(setegid,unistd.h)
 ICE_CHECK_DECL(seteuid,unistd.h)
 ICE_CHECK_DECL(setresgid,unistd.h)
 ICE_CHECK_DECL(setresuid,unistd.h)
-AC_CHECK_FUNCS(shquote)
 ICE_CHECK_DECL(snprintf,stdio.h)
 ICE_CHECK_DECL(vsnprintf,stdio.h)
 AMANDA_FUNC_SETPGID
@@ -359,6 +365,7 @@ dnl
 AC_CONFIG_FILES([
     Makefile
     amandad-src/Makefile
+    amar-src/Makefile
     amplot/Makefile
     changer-src/Makefile
     client-src/Makefile
@@ -366,14 +373,17 @@ AC_CONFIG_FILES([
     common-src/versuff.c
     config/Makefile
     device-src/Makefile
-    device-src/tests/Makefile
-    dumper-src/Makefile
+    application-src/Makefile
     example/Makefile
     example/amanda-client.conf
     example/amanda.conf
+    example/xinetd.amandaclient
+    example/xinetd.amandaserver
+    example/inetd.conf.amandaclient
+    example/inetd.conf.amandaserver
     example/chg-mcutil.conf
-    example/template.d/amanda-S3.conf
     example/template.d/advanced.conf
+    example/template.d/amanda-S3.conf
     example/template.d/amanda-harddisk.conf
     example/template.d/amanda-single-tape.conf
     example/template.d/amanda-tape-changer.conf
@@ -387,7 +397,7 @@ AC_CONFIG_FILES([
     recover-src/Makefile
     restore-src/Makefile
     server-src/Makefile
-    tape-src/Makefile
+    xfer-src/Makefile
 ])
 
 AC_OUTPUT