Imported Upstream version 2.6.1
[debian/amanda] / client-src / Makefile.am
index e21b7bb51cebde6278ab62901c52875b7db451ce..b0942bde921d3032c76947c2fb7296e2f6fdbe90 100644 (file)
@@ -70,12 +70,13 @@ INSTALLPERMS_data = chown=amanda \
        dest=$(amlibexecdir) $(amlibexec_SCRIPTS)
 
 if WANT_SETUID_CLIENT
-INSTALLPERMS_exec += dest=$(amlibexecdir) chown=root chmod=u+s,o-rwx \
+INSTALLPERMS_exec += dest=$(amlibexecdir) chown=root chmod=04750 \
                calcsize killpgrp rundump runtar
 endif
 
 lint:
        @ for p in $(amlibexec_PROGRAMS); do                                    \
+               p=`basename $$p $(EXEEXT)`;                                     \
                f="$$p.c $(libamclient_la_SOURCES)";                            \
                (cd ../common-src; make listlibsrc);                            \
                f="$$f "`cat ../common-src/listlibsrc.output`;                  \