lintian doesn't like orphan packages with uploaders...
[debian/amanda] / application-src / Makefile.am
index 17f1dea2b0d8f76c4ee3b9850f290a1c2a458f68..28419967bb98f45ad0a1295ad1e7abdcf84f9b3e 100644 (file)
@@ -15,7 +15,7 @@ LINT=$(AMLINT)
 LINTFLAGS=$(AMLINTFLAGS)
 
 AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
-AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
+AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS) $(AS_NEEDED_FLAGS)
 
 SCRIPTS_PERL = script-email \
             amlog-script \
@@ -48,13 +48,7 @@ LDADD = ../common-src/libamanda.la \
        ../common-src/libamanda.la \
        ../gnulib/libgnu.la
 
-INSTALLPERMS_exec = dest=$(amlibexecdir) chown=amanda $(amlibexec_PROGRAMS) \
-                   dest=$(applicationdir) chown=amanda $(applicationexec_PROGRAMS) \
-                   dest=$(applicationdir) chown=amanda $(applicationexec_SCRIPTS)
-
-INSTALLPERMS_data = dest=$(amlibexecdir) chown=amanda $(amlibexec_SCRIPTS)
-
 if WANT_SETUID_CLIENT
-INSTALLPERMS_exec += dest=$(applicationdir) chown=root chmod=04750 \
-                    amgtar amstar
+INSTALLPERMS_exec = dest=$(applicationdir) chown=root:setuid chmod=04750 \
+                   amgtar amstar
 endif