Imported Upstream version 2.6.1
[debian/amanda] / amandad-src / Makefile.am
index f62a51e0f32624e02845801f794581396967f3ed..768d0bbc26184284d2a9d0ff6909a17844eec2cd 100644 (file)
@@ -1,5 +1,6 @@
 # Makefile for Amanda client programs.
 
+include $(top_srcdir)/config/automake/vars.am
 include $(top_srcdir)/config/automake/installperms.am
 include $(top_srcdir)/config/automake/precompile.am
 
@@ -10,8 +11,8 @@ INCLUDES =    -I$(top_builddir)/common-src \
 AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
 AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
 
-LINT=@AMLINT@
-LINTFLAGS=@AMLINTFLAGS@
+LINT=$(AMLINT)
+LINTFLAGS=$(AMLINTFLAGS)
 
 amlib_LTLIBRARIES =       libamandad.la
 LIB_EXTENSION = la
@@ -46,6 +47,7 @@ INSTALLPERMS_data = \
 
 lint:
        @ for p in $(amlibexec_PROGRAMS); do                                    \
+               p=`basename $$p $(EXEEXT)`;                                     \
                f="$$p.c $(libamandad_la_SOURCES)";                             \
                (cd ../common-src; make listlibsrc);                            \
                f="$$f "`cat ../common-src/listlibsrc.output`;                  \