lintian doesn't like orphan packages with uploaders...
[debian/amanda] / Makefile.am
index b51faf45c52eeba6210a8ec3b25e41d083d5f95e..81589acec423f115687acc24e96885df843599fd 100644 (file)
@@ -1,22 +1,16 @@
 ## Process this file with automake to produce Makefile.in
-AUTOMAKE_OPTIONS = 1.4 foreign
+AUTOMAKE_OPTIONS = 1.10 foreign
 
-ACINCLUDE_M4 = $(srcdir)/acinclude.m4
-ACINCLUDE_M4I = $(srcdir)/config/acinclude.m4i
-LIBTOOL_M4I = $(srcdir)/config/libtool.m4i
-ACINCLUDE_M4_DEPS = $(ACINCLUDE_M4I) $(LIBTOOL_M4I)
+include $(top_srcdir)/config/automake/vars.am
+include $(top_srcdir)/config/automake/installperms.am
+
+ACLOCAL_AMFLAGS = --force -I config -I . -I config/gettext-macros -I config/gnulib -I config/amanda -I config/macro-archive
 
 if WANT_CLIENT
-CLIENT_SUBDIRS = client-src dumper-src
-endif
-if WANT_TAPE
-TAPE_SUBDIRS = tape-src
+CLIENT_SUBDIRS = client-src application-src
 endif
 if WANT_SERVER
-SERVER_SUBDIRS = server-src changer-src
-endif
-if WANT_RESTORE
-RESTORE_SUBDIRS = restore-src
+SERVER_SUBDIRS = device-src server-src changer-src
 endif
 if WANT_RECOVER
 RECOVER_SUBDIRS = recover-src oldrecover-src
@@ -24,26 +18,38 @@ endif
 if WANT_AMPLOT
 PLOT_SUBDIRS = amplot
 endif
+if WANT_NDMP
+NDMP_SUBDIRS = ndmp-src
+endif
 # order is significant, don't change it arbitrarily
-SUBDIRS = \
+SUBDIRS = . \
+       gnulib \
        config \
        common-src \
+       amar-src \
        amandad-src \
+       xfer-src \
+       $(NDMP_SUBDIRS) \
        $(TAPE_SUBDIRS) \
        $(CLIENT_SUBDIRS) \
        $(SERVER_SUBDIRS) \
        $(RESTORE_SUBDIRS) \
        $(RECOVER_SUBDIRS) \
        $(PLOT_SUBDIRS) \
-       man docs example
+       perl \
+       po \
+       man \
+       example \
+       packaging \
+       installcheck
 
 pkgdata_DATA = \
-       ReleaseNotes                    \
-       COPYRIGHT                       \
-       COPYRIGHT-APACHE                \
-       COPYRIGHT-REGEX
+       ReleaseNotes    \
+       COPYRIGHT       \
+       NEWS            \
+       ChangeLog
 
-EXTRA_DIST = $(SNAPSHOT_STAMP) \
+EXTRA_DIST += $(SNAPSHOT_STAMP) \
        $(pkgdata_DATA)                 \
         autogen                        \
        contrib/README                  \
@@ -65,37 +71,23 @@ EXTRA_DIST = $(SNAPSHOT_STAMP) \
        patches/regex-3.6alpha.patch    \
        patches/samba-largefs.patch     \
        patches/tar-1.12.patch          \
-       regex-src/COPYRIGHT             \
-       regex-src/Makefile              \
-       regex-src/README                \
-       regex-src/WHATSNEW              \
-       regex-src/cclass.h              \
-       regex-src/cname.h               \
-       regex-src/debug.c               \
-       regex-src/engine.c              \
-       regex-src/main.c                \
-       regex-src/mkh                   \
-       regex-src/regcomp.c             \
-       regex-src/regerror.c            \
-       regex-src/regex.3               \
-       regex-src/regex.7               \
-       regex-src/regex2.h              \
-       regex-src/regexec.c             \
-       regex-src/regfree.c             \
-       regex-src/split.c               \
-       regex-src/tests                 \
-       regex-src/utils.h               \
-       regex-src/fake/limits.h         \
-       regex-src/fake/memmove.c        \
-       regex-src/fake/stdlib.h
+       UPGRADING                       \
+       DEVELOPING                      \
+       VERSION                         \
+       FULL_VERSION
 
-$(ACINCLUDE_M4): $(ACINCLUDE_M4_DEPS)
-       @-rm -f $@
-       @cat $(ACINCLUDE_M4_DEPS) > $@
+FULL_VERSION: VERSION
+       $(srcdir)/config/set_full_version $(top_srcdir)
+
+config.status: FULL_VERSION
 
 libtool: $(LIBTOOL_DEPS)
        $(SHELL) ./config.status --recheck
 
+# empty out the installperms manifest file when we start
+install-exec-local: installperms-init
+install-data-local: installperms-init
+
 ## This is only meaningful for snapshots, but it won't hurt releases.
 CONFIG_STATUS = config.status
 $(CONFIG_STATUS): $(SNAPSHOT_STAMP)
@@ -109,10 +101,8 @@ lint:
        (cd common-src; make lint)
        (cd oldrecover-src; make lint)
        (cd recover-src; make lint)
-       (cd regex-src; make lint)
-       (cd restore-src; make lint)
        (cd server-src; make lint)
-       (cd tape-src; make lint)
+       (cd xfer-src; make lint)
 
 ## Do not release the *.test.c sources.  They get built on the fly and
 ## would contain a path from the distribution machine, which will just
@@ -120,3 +110,7 @@ lint:
 
 dist-hook:
        find $(distdir)/. -name '*.test.c' -exec rm {} \;
+
+# ensure that configure gets the right arguments for distcheck; this keeps the
+# user/group through to the distcheck, rather than defaulting back to 'amanda'.
+DISTCHECK_CONFIGURE_FLAGS = --with-user=$(CLIENT_LOGIN) --with-group=$(SETUID_GROUP) --with-owner=$(BINARY_OWNER) --disable-installperms --without-amperldir --without-force-uid --with-tmpdir=$(AMANDA_TMPDIR) SINGLE_USERID=yes CLOBBER_MY_CONFIG=OK