Imported Upstream version 2.6.0p2
[debian/amanda] / ChangeLog
index 42929cf126d5d044973e2a6e646b0e797e672493..e671971a8cdbcfc14a817bad211e0b90a74e51a6 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,235 @@
+2008-08-22  Jean-Louis Martineau <martineau@zmanda.com>
+       * configure.in, packaging/deb/rules,
+         packaging/deb/buildpkg, packaging/rpm/buildpkg,
+         packaging/rpm/amanda.spec: Change release to 2.6.0p2
+       * NEWS: News in 2.6.0p2
+
+2008-08-22  Dustin J. Mitchell <dustin@zmanda.com>
+       * perl/amglue/bigint.c: add #include "stdint.h"
+
+2008-08-22  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/amadmin.c (tape): Correctly print next tape to use.
+       * server-src/tapefile.c (print_new_tapes): New function to print new
+                                                  tapes.
+       * server-src/tapefile.h (print_new_tapes): Prototype.
+       * server-src/reporter.c: Correctly print next tape to use.
+
+2008-08-22  Dustin J. Mitchell <dustin@zmanda.com>
+       Thanks to Stefan G. Weichinger <sgw@amanda.org>
+       * server-src/taper.c: check errors from device, and handle them by
+         either requesting a new tape or just using the next tape in the
+         changer
+
+2008-08-22  Olivier Nicole <on@cs.ait.ac.th>
+       * changer-src/chg-disk.sh: replace == with =
+
+2008-08-22  Dustin J. Mitchell <dustin@zmanda.com>
+       * changer-src/chg-lib.sh.in: fix sed invocation for BSD's sed
+
+2008-08-22  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/reporter.c: Fix computation of compression ratio.
+
+2008-08-21  Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/krb5-security.c: Fix security_seterror use.
+
+2008-08-21  Jean-Louis Martineau <martineau@zmanda.com>
+       * device-src/queueing.c: Fix compiler warning.
+
+2008-08-19  Dustin J. Mitchell <dustin@zmanda.com>
+       * configure.in: check for getgrgid_r and getpwuid_r
+       * common-src/security-util.c: conditionalize on checks
+
+2008-08-18  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/version.h: remove #include of config.h
+       * device-src/vfs-device.c: #include amanda.h first
+
+2008-08-15  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/debug.c: include backtraces on fatal errors
+       * config/amanda/debugging.m4: look for glibc's backtrace support
+       * configure.in: ditto
+
+2008-08-05 Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/amanda.spec:  Merged fixes from trunk .spec for
+         parsing redhat-release for fedora versions correctly.
+
+2008-08-04 Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/amanda.spec:  add %{tarver} macro and set the correct
+         minimum version per distro (Thanks to Jesse Angell for the rhel4 tip)
+
+2008-07-30  Dustin J. Mitchell <dustin@zmanda.com>
+       * perl/Amanda/Changer.pm perl/Amanda/Cmdline.swg
+         perl/Amanda/Config.swg perl/Amanda/DB/Catalog.pm
+         perl/Amanda/Device.swg perl/Amanda/Logfile.swg 
+         perl/Amanda/Util.swg: POD cleanup
+       * perl/Makefile.am: new files, rules to make HTML
+       * perl/amperl.css: CSS file for online POD
+       * perl/make_html.pl: make online POD
+
+2008-07-30  Dustin J. Mitchell <dustin@zmanda.com>
+       * man/Makefile.am man/amanda.css man/index.php man/xslt/html.xsl.in:
+         new files for HTML output
+       * man/xslt/man.xsl.in: substitute XSLT_VERS
+       * man/xml-source/amanda-devices.7.xml: tweaks
+       * man/xml-source/amanda.8.xml: tweaks
+       * man/xml-source/amanda.conf.5.xml: tweaks
+       * man/xml-source/amgetconf.8.xml: tweaks
+       * man/xml-source/amtoc.8.xml: tweaks
+
+2008-07-30 Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/amanda.spec: removed activate-devpay from %files section
+
+2008-07-30 Dan Locks <dwlocks@zmanda.com>
+       * device-src/s3.c: Merged changes from 968 to work around a libcurl bug.
+       * config/amanda/s3-device.m4: Same
+
+2008-07-30  Dustin J. Mitchell <dustin@zmanda.com>
+       * installcheck/Amanda_Config.pl: add + to avoid perl-5.6.0 parsing bug
+       * installcheck/amgetconf.pl: ditto
+
+2008-07-28  Dustin J. Mitchell <dustin@zmanda.com>
+       * client-src/sendsize.c: remove cruft causing compile errors on HP/UX
+
+2008-07-28  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/tests/semaphore-test.c: move function call out of
+         variable initialization
+
+2008-07-25 Dan Locks <dwlocks@zmanda.com>
+       * packaging/deb/control: added alternative dependency of libssl0.9.8 for
+         Ubuntu 8.x builds.  Added build dependencies for debhelper, fakeroot,
+         libcurl-dev, libssl-dev.  Updated server and client dependency for curl
+         to libcurl3
+
+2008-07-23  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/conffile.c: fix handling for config overwrites of
+         non-string parameters
+
+2008-07-17  Jean-Louis Martineau <martineau@zmanda.com>
+       * amandad-src/amandad.c: amandad must be run by root for krb5 auth.
+
+200i-07-14 Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/amanda.spec: fix distribution detection, add
+       activate-devpay to server files list
+
+2008-07-11  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/rait-device.c: fix RAIT file numbers; don't pass
+         block-size-related properties down to child devices (we set the block
+         size in find_block_size); don't use union_robust for checking whether
+         labels changed, as it causes spurious failures
+
+2008-07-11  Dustin J. Mitchell <dustin@zmanda.com>
+       Thanks to Stefan G. Weichinger <sgw@amanda.org>
+       * device-src/tape-*.c: return DEVICE_ERROR|VOLUME_MISSING on EIO while
+         checking tape_is_tape_device
+       * changer-src/chg-lib.sh.in: keep waiting for a device if it *might*
+         be busy or offline
+
+2008-07-09  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/rait-device.c: rewrite g_ptr_array_union_robust to
+         correctly detect and handle child device failures
+
+2008-07-09  Dustin J. Mitchell <dustin@zmanda.com>
+       * perl/Amanda/Logfile.swg: POD tweaks
+
+2008-07-06 Dan Locks <dwlocks@zmanda.com>
+       * packaging/deb/amanda-backup-server.postrm
+         packaging/deb/amanda-backup-client.postrm: removed unused
+         code
+       * packaging/deb/postrm: fixed typo in deluser command
+       * packaging/deb/rules: added specific preinst and postrm scripts for
+         client and server.
+
+2008-07-04 Dan Locks <dwlocks@zmanda.com>
+       * packaging/rpm/buildpkg: add lines to copy rpms to root of the build dir.
+
+2008-06-30  Ian Turner <ian@zmanda.com>
+       * device-src/rait-device.c: Fix a memory corruption issue on the last
+         block of a file.
+       * device-src/rait-device.c: Track file numbers properly when child
+         devices change them (that is, in rait_device_start_file() and
+         rait_device_seek_file()).
+
+2008-06-27  Ian Turner <ian@zmanda.com>
+       * device-src/rait-device.c (rait_device_start): Check for consistent
+         volume label on all child devices, otherwise fail
+
+2008-06-27  Ian Turner <ian@zmanda.com>
+       * device-src/rait-device.c: Silence a compiler warning.
+
+2008-06-27  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/rait-device.c: hack around glib bug in versions <2.10.2
+
+2008-06-09  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/conffile.c: don't complain about a missing client conf
+         file, as the complaint interferes with the network communication
+         ("invalid size: could not open conf file")
+
+2008-06-06  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/*: bugfixes backported from trunk r1087
+         - device_read_block returns an int, not a gboolean, and sets in_file
+           = FALSE on EOF
+         - tape device only requires a label in READ and APPEND modes
+         - tape device isn't opened until start or read_label
+         - rait sets self->file correctly in start
+         - rait compares child devices' labels and times correctly
+         - vfs correctly chains up in property_get
+         - vfs sets self->file correctly in start with ACCESS_APPEND
+
+2008-06-03  Jean-Louis Martineau <martineau@zmanda.com>
+       * man/xml-source/amdump.8.xml, man/xml-source/amreport.8.xml,
+         man/xml-source/amcheck.8.xml, man/xml-source/amflush.8.xml,
+         man/xml-source/amstatus.8.xml: Add "EXIT CODE" section".
+
+2008-05-30  Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/security-util.c: Remove unneeded pointer cast.
+       * common-src/stream.c: Fix compiler error.
+
+2008-05-30  Dustin J. Mitchell <dustin@zmanda.com>
+       * common-src/amanda.h, common-src/bsd-security.c,
+         common-src/bsdtcp-security.c, common-src/bsdudp-security.c,
+         common-src/dgram.c, common-src/dgram.h, common-src/krb5-security.c,
+         common-src/security-util.c, common-src/security-util.h,
+         common-src/sockaddr-util.c, common-src/sockaddr-util.h,
+         common-src/stream.c, common-src/util.c, common-src/util.h,
+         restore-src/amidxtaped.c, server-src/amindexd.c: add sockaddr_union,
+         change all relevant functions to use it, to avoid aliasing violations
+
+2008-05-29  Orion Poplawski <orion@cora.nwra.com>
+       * device-src/tests/semaphore-test.c: fix call to amanda_thread_init
+       * device-src/tests/vfs_test.c: fix call to amanda_thread_init
+       * server-src/chunker.c: fix buffer overrun
+
+2008-05-29  Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/conffile.c (client_keytab): Remove "DEVICE-PROPERTY".
+
+2008-05-28  Dustin J. Mitchell <dustin@zmanda.com>
+       * device-src/rait-device.c: rait-device returns correct size when
+         blocksize is too small
+
+2008-05-25  Jean-Louis Martineau <martineau@zmanda.com>
+       * changer-src/chg-zd-mtx.sh: Fix logging.
+
+2008-05-25  Jean-Louis Martineau <martineau@zmanda.com>
+        * packaging/rpm/amanda.spec: Fix output message.
+
+2008-05-21  Jean-Louis Martineau <martineau@zmanda.com>
+       * server-src/driver.c: Fix quoting of diskname.
+
+2008-05-20  Dustin J. Mitchell <dustin@zmanda.com>
+       * configure.in config/amanda/socklen_t_equiv.m4: detect the type (not
+         necessarily socklen_t used by getpeername et al.
+       * amandad-src/amandad.c server-src/amindexd.c restore-src/amidxtaped.c
+         common-src/util.c common-src/bsdtcp-security.c common-src/amanda.h
+         common-src/krb5-security.c common-src/dgram.c common-src/stream.c:
+         use the type instead of socklen_t
+
+2008-05-14  Dustin J. Mitchell <dustin@zmanda.com>
+       * client-src/amhpfixdevs.sh client-src/Makefile.am
+         client-src/amsinixfixdevs.sh config/amanda/devprefix.m4:
+         permanently remove amsinixfixdevs and amhpfixdevs
+
+2008-05-16  Jean-Louis Martineau <martineau@zmanda.com>
+       * common-src/conffile.c: Fix conf_parserror use.
+
 2008-05-13 Dan Locks <dwlocks@zmanda.com>
        * packaging/deb/buildpkg: modified build script to create unsigned
          packages