tests: make all test scripts executable; work with automake-1.12
authorJim Meyering <meyering@redhat.com>
Wed, 11 Jan 2012 20:35:41 +0000 (21:35 +0100)
committerJim Meyering <meyering@redhat.com>
Wed, 11 Jan 2012 20:35:41 +0000 (21:35 +0100)
* tests/Makefile.am (TESTS_ENVIRONMENT): Adapt to work with upcoming
automake-1.12.
* tests/mixed: Make executable.
* tests/zgrep-f: Likewise.
* tests/zgrep-signal: Likewise.
* tests/znew-k: Likewise.

tests/Makefile.am
tests/mixed [changed mode: 0644->0755]
tests/zgrep-f [changed mode: 0644->0755]
tests/zgrep-signal [changed mode: 0644->0755]
tests/znew-k [changed mode: 0644->0755]

index 9e4b2414fed4d3f33f45ea0dbb92243a4f9bed85..3b6ec31c22ed4247e478910fbfb627a3c356e86e 100644 (file)
@@ -52,7 +52,6 @@ built_programs = \
 TESTS_ENVIRONMENT =                            \
   tmp__=$$TMPDIR; test -d "$$tmp__" || tmp__=.;        \
   TMPDIR=$$tmp__; export TMPDIR;               \
-  exec 9>&2;                                   \
   shell_or_perl_() {                           \
     if grep '^\#!/usr/bin/perl' "$$1" > /dev/null; then                        \
       if $(PERL) -e 'use warnings' > /dev/null 2>&1; then              \
@@ -85,6 +84,6 @@ TESTS_ENVIRONMENT =                           \
   PERL='$(PERL)'                               \
   SHELL='$(SHELL)'                             \
   PATH='$(abs_top_builddir)$(PATH_SEPARATOR)'"$$PATH" \
-  ; shell_or_perl_
+  ; 9>&2
 
 VERBOSE = yes
old mode 100644 (file)
new mode 100755 (executable)
old mode 100644 (file)
new mode 100755 (executable)
old mode 100644 (file)
new mode 100755 (executable)
old mode 100644 (file)
new mode 100755 (executable)