build: update gnulib submodule to latest, and adapt
authorJim Meyering <meyering@redhat.com>
Mon, 5 Apr 2010 18:56:19 +0000 (20:56 +0200)
committerJim Meyering <meyering@redhat.com>
Tue, 6 Apr 2010 06:24:41 +0000 (08:24 +0200)
* cfg.mk: Update to use new _sc_search_regexp interface.  Run this:
perl -pi -e 's/\b_prohibit_regexp\b/_sc_search_regexp/;'
-e 's/\bmsg=/halt=/; s/\bre=/prohibit=/;' cfg.mk
and then adjust backslashes so they still line up.
* cfg.mk (local-checks-to-skip): Add new sc_texinfo_acronym, to skip it.
* msdos/tailor.c (fcalloc): Mark a diagnostic for translation, to
placate stricter syntax-check, even though no one uses this file.

cfg.mk
gnulib
lib/.gitignore
m4/.gitignore
msdos/tailor.c

diff --git a/cfg.mk b/cfg.mk
index 61e8cfe0365150ca6ddc0db8e06d34dba67459ee..879637b787f1c8ef91e658bd2512f3063234674a 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -28,6 +28,7 @@ local-checks-to-skip =                \
   sc_prohibit_atoi_atof                \
   sc_prohibit_stat_st_blocks   \
   sc_space_tab                 \
+  sc_texinfo_acronym           \
   sc_useless_cpp_parens
 
 
@@ -42,9 +43,9 @@ old_NEWS_hash = e35901d8427a032d2b88a3195ed24a8f
 sc_obs_header_regex = \
   \<(STDC_HEADERS|HAVE_(LIMITS|STRING|UNISTD|STDLIB)_H)\>
 sc_prohibit_obsolete_HAVE_HEADER_H:
-       @re='^[  ]*#[    ]*(el)?if.*$(sc_obs_header_regex)' \
-       msg='remove the above obsolete #if...HAVE_HEADER_H test(s)' \
-         $(_prohibit_regexp)
+       @prohibit='^[    ]*#[    ]*(el)?if.*$(sc_obs_header_regex)' \
+       halt='remove the above obsolete #if...HAVE_HEADER_H test(s)' \
+         $(_sc_search_regexp)
 
 update-copyright-env = \
   UPDATE_COPYRIGHT_USE_INTERVALS=1 \
@@ -52,14 +53,14 @@ update-copyright-env = \
 
 # Indent only with spaces.
 sc_prohibit_tab_based_indentation:
-       @re='^ *        '                                               \
-       msg='TAB in indentation; use only spaces'                       \
-         $(_prohibit_regexp)
+       @prohibit='^ *  '                                               \
+       halt='TAB in indentation; use only spaces'                      \
+         $(_sc_search_regexp)
 
 # Don't use "indent-tabs-mode: nil" anymore.  No longer needed.
 sc_prohibit_emacs__indent_tabs_mode__setting:
-       @re='^( *[*#] *)?indent-tabs-mode:'                             \
-       msg='use of emacs indent-tabs-mode: setting'                    \
-         $(_prohibit_regexp)
+       @prohibit='^( *[*#] *)?indent-tabs-mode:'                       \
+       halt='use of emacs indent-tabs-mode: setting'                   \
+         $(_sc_search_regexp)
 
 include $(srcdir)/dist-check.mk
diff --git a/gnulib b/gnulib
index 9d0ad652de159d08e5f679842f8a2a5658196361..fb814d4cf9834324f0c05bcd04899003933933fa 160000 (submodule)
--- a/gnulib
+++ b/gnulib
@@ -1 +1 @@
-Subproject commit 9d0ad652de159d08e5f679842f8a2a5658196361
+Subproject commit fb814d4cf9834324f0c05bcd04899003933933fa
index 461e93b07319c29a4fa2b7ea41dfb5b89ca8c7a4..2916a59017cc60d21fadc815e9e4d9765d09286f 100644 (file)
@@ -11,6 +11,8 @@ charset.alias
 chdir-long.c
 chdir-long.h
 chown.c
+cloexec.c
+cloexec.h
 close-hook.c
 close-hook.h
 close-stream.c
@@ -73,6 +75,7 @@ fseterr.h
 fstatat.c
 ftello.c
 getcwd.c
+getdtablesize.c
 getopt.c
 getopt.h
 getopt.in.h
index 657e29f50c93c767f05e1daa2c8a77a75190300a..ff53b601a54d4df4727d7128a293b18faaee2c85 100644 (file)
@@ -5,6 +5,7 @@ calloc.m4
 chdir-long.m4
 chown.m4
 clock_time.m4
+cloexec.m4
 close-stream.m4
 close.m4
 closein.m4
@@ -45,6 +46,7 @@ ftello.m4
 getcwd-abort-bug.m4
 getcwd-path-max.m4
 getcwd.m4
+getdtablesize.m4
 getopt.m4
 getpagesize.m4
 gettime.m4
@@ -124,8 +126,10 @@ vfprintf-posix.m4
 warn-on-use.m4
 warnings.m4
 wchar.m4
+wchar_h.m4
 wchar_t.m4
 wctype.m4
+wctype_h.m4
 wint_t.m4
 xalloc.m4
 xgetcwd.m4
index af9d5dab22c72de7ec94e9d02b8e88e7067fb81d..1d6d6ef4b2b63508ea164fadd2e2b0bc6f526682 100644 (file)
@@ -36,7 +36,7 @@ void * fcalloc(items, size)
     if (ptr_offset == 0) {
         ptr_offset = (ush)((uch*)buf-0);
     } else if (ptr_offset != (ush)((uch*)buf-0)) {
-        error("inconsistent ptr_offset");
+        error(_("inconsistent ptr_offset"));
     }
     *((ush*)&buf+1) += (ptr_offset + 15) >> 4;
     *(ush*)&buf = 0;