Fix build failure on case-insensitive file systems.
authorPaul Eggert <eggert@cs.ucla.edu>
Thu, 7 Dec 2006 07:23:35 +0000 (07:23 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Thu, 7 Dec 2006 07:23:35 +0000 (07:23 +0000)
* configure.ac: Use match_.s instead of _match.s.
* Makefile.am (MOSTLYCLEANFILES): Likewise.
* lib/Makefile.am (match.$(OBJEXT)): Likewise.
(MOSTLYCLEANFILES): Likewise.

ChangeLog
Makefile.am
configure.ac
lib/Makefile.am

index fe6b005fa319f2dfde44a9f17a64236147b29df5..fe8b8b946b229b9b636fc39576eb70afeb47d243 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,12 @@
+2006-12-05  Bruno Haible  <bruno@clisp.org>  (tiny change)
+       and Paul Eggert  <eggert@cs.ucla.edu>
+
+       Fix build failure on case-insensitive file systems.
+       * configure.ac: Use match_.s instead of _match.s.
+       * Makefile.am (MOSTLYCLEANFILES): Likewise.
+       * lib/Makefile.am (match.$(OBJEXT)): Likewise.
+       (MOSTLYCLEANFILES): Likewise.
+
 2006-12-06  Paul Eggert  <eggert@cs.ucla.edu>
 
        * NEWS: Document the fixes below.
index 2bb19548f2af4e1103b26b2cc066c75988a8b109..9ec8c77d03d043cc3ce3a231091de9341dcbd989 100644 (file)
@@ -98,4 +98,4 @@ uninstall-local: remove-installed-links
 
 MAINTAINERCLEANFILES = gzip.doc
 
-MOSTLYCLEANFILES = _match.s _match.S gzexe zdiff zforce zgrep zless zmore znew
+MOSTLYCLEANFILES = match_.s _match.S gzexe zdiff zforce zgrep zless zmore znew
index c3271afc4c9fa3f6b468d442278d080a93a57740..11f272ec408b585be6c173d4ac0a1469ba68ecff 100644 (file)
@@ -59,15 +59,15 @@ AC_CACHE_CHECK([for assembler], [gzip_cv_assembler],
    *' NO_ASM '*) ;;
    *)
      if cp $srcdir/lib/match.c _match.S &&
-        eval "$ASCPP _match.S > _match.s 2>/dev/null"; then
-       if test ! -s _match.s || grep error < _match.s > /dev/null; then
+       eval "$ASCPP _match.S > match_.s 2>/dev/null"; then
+       if test ! -s match_.s || grep error < match_.s > /dev/null; then
         :
-       elif eval "$CC -c _match.s >/dev/null 2>&1" &&
-           test -f _match.$OBJEXT; then
+       elif eval "$CC -c match_.s >/dev/null 2>&1" &&
+           test -f match_.$OBJEXT; then
         gzip_cv_assembler=yes
        fi
      fi
-     rm -f _match.S _match.s _match.$OBJEXT;;
+     rm -f _match.S match_.s match_.$OBJEXT;;
    esac])
 if test $gzip_cv_assembler = yes; then
   AC_DEFINE(ASMV, ,
index 1f5a6d8cddddd5576fef1dd607756f2a086c77f4..f97ca3b8c86edbf8ce828d0b296e4994e159e9cc 100644 (file)
@@ -27,9 +27,9 @@ LN_S = @LN_S@
 
 match.$(OBJEXT): match.c
        cp $(srcdir)/match.c _match.S
-       $(ASCPP) _match.S >_match.s
-       $(CC) -c $(CFLAGS) _match.s
-       mv _match.$(OBJEXT) match.$(OBJEXT)
-       rm -f _match.S _match.s
+       $(ASCPP) _match.S > match_.s
+       $(CC) -c $(CFLAGS) match_.s
+       mv match_.$(OBJEXT) $@
+       rm -f _match.S match_.s
 
-MOSTLYCLEANFILES += _match.S _match.s
+MOSTLYCLEANFILES += _match.S match_.s