fixes ticket:144; works around g++/PPC -O1 bug
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 30 Aug 2007 00:11:16 +0000 (00:11 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 30 Aug 2007 00:11:16 +0000 (00:11 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@6212 221aa14e-8319-0410-a670-987f0aec2ac5

configure.ac

index bdb1eae8f1a3ac2440c56acc3d89b5250f93f0f5..6993103940b5c4596b356ed13b967d9d7183d6d0 100644 (file)
@@ -49,14 +49,11 @@ if test "$user_set_cxxflags" != yes; then
   autoconf_default_CXXFLAGS="$CXXFLAGS"
   CXXFLAGS=""
   if test "$GXX" = yes; then
-    case "$host_os" in
-       darwin*)
-       if test "$host_cpu" = i386; then
-          swig_CXXFLAGS="-g1 -O1"
-       else
-          # "-O1" breaks PPC-OSX for some reason
+    case "$host_cpu" in
+       powerpc*)
+          # "-O1" is broken on the PPC for some reason
+          # (at least as of g++ 4.1.1)
           swig_CXXFLAGS="-g1 -O2"
-       fi      
        ;;
        *) 
        swig_CXXFLAGS="-g1 -O1"