Merge branch 'prefix' of git://gnuradio.org/jabele
authorJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 11 Feb 2010 16:18:46 +0000 (08:18 -0800)
committerJohnathan Corgan <jcorgan@corganenterprises.com>
Thu, 11 Feb 2010 16:18:46 +0000 (08:18 -0800)
usrp/firmware/src/common/build_eeprom.py
usrp/firmware/src/usrp2/Makefile.am

index 023c4b3f5797ba79b9144684f856f53f82144f71..ed9bb56a4816174b3d0d02f04ed64559a1022b16 100755 (executable)
@@ -140,12 +140,12 @@ def build_eeprom_image (filename, rev):
     assert (len (image) <= 256)
     return image
 
-def build_shell_script (out, ihx_filename, rev):
+def build_shell_script (out, ihx_filename, rev, prefix):
 
     image = build_eeprom_image (ihx_filename, rev)
 
     out.write ('#!/bin/sh\n')
-    out.write ('usrper -x load_firmware /usr/local/share/usrp/rev%d/std.ihx\n' % rev)
+    out.write ('usrper -x load_firmware ' + prefix + '/share/usrp/rev%d/std.ihx\n' % rev)
     out.write ('sleep 1\n')
     
     # print "len(image) =", len(image)
@@ -164,8 +164,10 @@ def build_shell_script (out, ihx_filename, rev):
         out.write ('sleep 1\n')
 
 if __name__ == '__main__':
-    usage = "usage: %prog -r REV [options] bootfile.ihx"
+    usage = "usage: %prog -p PREFIX -r REV [options] bootfile.ihx"
     parser = OptionParser (usage=usage)
+    parser.add_option ("-p", "--prefix", type="string", default="",
+                       help="Specify install prefix from configure")
     parser.add_option ("-r", "--rev", type="int", default=-1,
                        help="Specify USRP revision number REV (2 or 4)")
     (options, args) = parser.parse_args ()
@@ -176,7 +178,15 @@ if __name__ == '__main__':
         sys.stderr.write (
             "You must specify the USRP revision number (2 or 4) with -r REV\n")
         sys.exit (1)
+    if options.prefix == "":
+        sys.stderr.write (
+            "You must specify the install prefix with -p PREFIX\n")
+        sys.exit (1)
+    if not os.path.isdir(options.prefix):
+        sys.stderr.write (
+            "PREFIX dir (" + options.prefix + "), does not exist\n")
+        sys.exit (1)
 
     ihx_filename = args[0]
 
-    build_shell_script (sys.stdout, ihx_filename, options.rev)
+    build_shell_script (sys.stdout, ihx_filename, options.rev, options.prefix)
index e380b19074b41782ba211fd9f0fb62aff43b52c0..4402cd6365901e4cba936a26f7d3d41448e63b42 100644 (file)
@@ -108,11 +108,11 @@ eeprom_boot.ihx: $(EEPROM_BOOT_OBJS) $(LIBDEP)
        $(XCC) $(LINKOPTS) -o $@ $(EEPROM_BOOT_OBJS)
 
 burn-usrp2-eeprom: eeprom_boot.ihx
-       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r2 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -p$(prefix) -r2 eeprom_boot.ihx > $@
        chmod +x $@
 
 burn-usrp4-eeprom: eeprom_boot.ihx
-       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r4 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -p$(prefix) -r4 eeprom_boot.ihx > $@
        chmod +x $@