doc: describe release procedure
authorJim Meyering <meyering@redhat.com>
Thu, 1 Oct 2009 09:20:44 +0000 (11:20 +0200)
committerJim Meyering <meyering@redhat.com>
Fri, 2 Oct 2009 08:41:17 +0000 (10:41 +0200)
* README-release: New file.

README-release [new file with mode: 0644]

diff --git a/README-release b/README-release
new file mode 100644 (file)
index 0000000..90d03fd
--- /dev/null
@@ -0,0 +1,83 @@
+Here are most of the steps we (maintainers) follow when making a release.
+
+* start from a clean, up-to-date git directory.
+
+    git checkout master; git pull
+
+* Run ./configure && make maintainer-clean
+
+* Ensure that the desired versions of autoconf, automake, etc.
+  are in your PATH.  See the buildreq list in bootstrap.conf for
+  the complete list.
+
+* Ensure that you're on "master" with no uncommitted diffs.
+  This should produce no output: git checkout master; git diff
+
+* Run bootstrap: ./bootstrap
+
+* Pre-release testing:
+  Ensure that make check syntax-check succeeds.
+
+* Run "make distcheck"
+
+* Manually set the date, version number, and [stable/alpha/beta] on
+  line 3 of NEWS, then do e.g.,:
+
+    v=1.3.13
+    pkg=$(sed -n 's/^PACKAGE = \(.*\)/\1/p' Makefile)
+    git commit -F <(printf 'version '$v'\n\n* NEWS: Record release date.\n') -a
+    git tag -s -m "$pkg $v" v$v HEAD
+
+* Run the following to create release tarballs.  Your choice selects the
+  corresponding upload-to destination in the emitted gnupload command.
+  The different destinations are specified in cfg.mk.  See the definitions
+  of gnu_ftp_host-{alpha,beta,stable}.
+
+    # "TYPE" must be stable, beta or alpha
+    make TYPE
+
+* Test the tarball.  copy it to a few odd-ball systems and ensure that
+  it builds and passes all tests.
+
+* While that's happening, write the release announcement that you will
+  soon post.
+
+Once all the builds and tests have passed,
+
+* Run the gnupload command that was suggested by your "make major" run above.
+
+* Wait a few minutes (maybe up to 30?) and then use the release URLs to
+  download all tarball/signature pairs and use gpg --verify to ensure
+  that they're all valid.
+
+* Push the new tag:
+
+    v=$(cat .prev-version)
+    git push origin tag v$v
+
+* Send the gpg-signed announcement mail, e.g.,
+
+    To: info-gnu@gnu.org
+    Cc: coordinator@translationproject.org, bug-gzip@gnu.org
+    Subject: gzip-1.3.13 released [stable]
+
+* Announce it on Savannah, too:
+  From here:
+    https://savannah.gnu.org/projects/gzip/
+  click on the "submit news", then write something like the following:
+  (If there is no such button, then enable "News" for the project via
+   the Main -> "Select Features" menu item, or via this link:
+   https://savannah.gnu.org/project/admin/editgroupfeatures.php?group=gzip)
+
+    Subject: gzip-1.3.13 released [stable]
+    The announcement is here:
+      http://article.gmane.org/gmane.comp.gnu.gzip.bugs/258
+
+  Then go here to approve it:
+    https://savannah.gnu.org/news/approve.php?group=gzip
+
+* After each non-alpha release, update the on-line manual accessible via
+
+    http://www.gnu.org/software/gzip/manual/
+
+  by running the gnu-web-doc-update script.