use sudo as the init.d script name for both sudo and sudo-ldap packages
authorBdale Garbee <bdale@gag.com>
Sun, 6 Jul 2008 07:01:43 +0000 (01:01 -0600)
committerBdale Garbee <bdale@gag.com>
Sun, 6 Jul 2008 07:01:43 +0000 (01:01 -0600)
debian/rules
debian/sudo-ldap.postinst

index 365c062423976c8ce3e783d5309df25e4b21d6e1..fd9c2b348c3f60862a1355f8d0c37a9815f50209 100755 (executable)
@@ -103,7 +103,7 @@ binary-arch: build install
        dh_testroot
        dh_installdocs
        dh_installexamples -A sudoers
-       dh_installinit -psudo -psudo-ldap
+       dh_installinit -psudo -psudo-ldap --name=sudo
        dh_installmanpages fnmatch.3
        dh_installinfo -A
        dh_installchangelogs CHANGES
index 854f0ab5738a0c12252cdba76c3f41167c9dbe62..36cdd235c89e4de80576edfa280def1318d16944 100644 (file)
@@ -31,9 +31,9 @@ system ('chown root:root /etc/sudoers');
 system ('chmod 440 /etc/sudoers');
 
 # must do a remove first to un-do the "bad" links created by previous version
-system ('update-rc.d -f sudo-ldap remove >/dev/null 2>&1');
+system ('update-rc.d -f sudo remove >/dev/null 2>&1');
 
-system ('update-rc.d sudo-ldap start 75 S . >/dev/null');
+system ('update-rc.d sudo start 75 S . >/dev/null');
 
 # make sure we have a sudo group