oops, we need to restore the sudo-ldap init.d too!
authorBdale Garbee <bdale@gag.com>
Sun, 6 Jul 2008 06:05:32 +0000 (00:05 -0600)
committerBdale Garbee <bdale@gag.com>
Sun, 6 Jul 2008 06:05:32 +0000 (00:05 -0600)
debian/rules
debian/sudo-ldap.init.d [new file with mode: 0644]

index 562b523de8fb00ced4aa3b7d06d36d735ca55589..365c062423976c8ce3e783d5309df25e4b21d6e1 100755 (executable)
@@ -103,8 +103,7 @@ binary-arch: build install
        dh_testroot
        dh_installdocs
        dh_installexamples -A sudoers
-       dh_installinit -psudo
-       dh_installinit -psudo-ldap
+       dh_installinit -psudo -psudo-ldap
        dh_installmanpages fnmatch.3
        dh_installinfo -A
        dh_installchangelogs CHANGES
diff --git a/debian/sudo-ldap.init.d b/debian/sudo-ldap.init.d
new file mode 100644 (file)
index 0000000..cdd54db
--- /dev/null
@@ -0,0 +1,31 @@
+#! /bin/sh
+
+### BEGIN INIT INFO
+# Provides:          sudo
+# Required-Start:    $local_fs $remote_fs
+# Required-Stop:
+# Default-Start:     S 
+# Default-Stop:
+### END INIT INFO
+
+N=/etc/init.d/sudo
+
+set -e
+
+case "$1" in
+  start)
+       # make sure privileges don't persist across reboots
+       if [ -d /var/run/sudo ]
+       then
+                find /var/run/sudo -exec touch -t 198501010000 '{}' \;
+       fi
+       ;;
+  stop|reload|restart|force-reload)
+       ;;
+  *)
+       echo "Usage: $N {start|stop|restart|force-reload}" >&2
+       exit 1
+       ;;
+esac
+
+exit 0