* Makefile.am (gzip.doc.gz, check-local): Depend on $(bin_PROGRAMS).
authorPaul Eggert <eggert@cs.ucla.edu>
Thu, 4 Oct 2007 22:25:07 +0000 (22:25 +0000)
committerPaul Eggert <eggert@cs.ucla.edu>
Thu, 4 Oct 2007 22:25:07 +0000 (22:25 +0000)
(gzip.doc.gz): Use our gzip, not the system-installed one.
Problem reported by Chris Staub in
<http://lists.gnu.org/archive/html/bug-gzip/2007-10/msg00000.html>.

ChangeLog
Makefile.am

index 5f686f2c9dcb2b5af029a6a827bee1d6ae4b5382..c7a0cebde0073f280143d61fb3cd5b6a3a51d867 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2007-10-04  Paul Eggert  <eggert@cs.ucla.edu>
+
+       * Makefile.am (gzip.doc.gz, check-local): Depend on $(bin_PROGRAMS).
+       (gzip.doc.gz): Use our gzip, not the system-installed one.
+       Problem reported by Chris Staub in
+       <http://lists.gnu.org/archive/html/bug-gzip/2007-10/msg00000.html>.
+
 2007-07-03  Paul Eggert  <eggert@cs.ucla.edu>
 
        * COPYING: Update to GPLv3.  All uses changed.
index 373160b27e968fdc90fb9ffb5c90c23bb460798b..6e168ab1f0c75fac5e7e6d1b819385005bcd7fc9 100644 (file)
@@ -49,8 +49,8 @@ gzip_LDADD = lib/libgzip.a
 gzip.doc: gzip.1
        groff -man -Tascii $(srcdir)/gzip.1 | col -b | uniq >$@
 
-gzip.doc.gz: gzip.doc
-       gzip <$? >$@
+gzip.doc.gz: gzip.doc $(bin_PROGRAMS)
+       ./gzip <gzip.doc >$@
 
 SUFFIXES = .in
 .in:
@@ -64,7 +64,7 @@ SUFFIXES = .in
 # A simple test, just of gzip -- more of a sanity check than anything else.
 FILES_TO_CHECK = $(bin_SCRIPTS) $(gzip_LDADD) \
   $(top_srcdir)/ChangeLog $(top_srcdir)/configure $(top_srcdir)/gzip.c
-check-local: $(FILES_TO_CHECK) gzip.doc.gz
+check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
        { test '$(srcdir)' != . || ./zdiff --__bindir . -c gzip.doc.gz; }
        ./zdiff --__bindir . -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
        ./zdiff --__bindir . $(srcdir)/gzip.doc gzip.doc.gz