Fix include paths for VPATH build (Michael Dickens). Note, this was one of thoses...
authorjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 25 Dec 2008 20:03:00 +0000 (20:03 +0000)
committerjcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Thu, 25 Dec 2008 20:03:00 +0000 (20:03 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@10167 221aa14e-8319-0410-a670-987f0aec2ac5

config/grc_usrp.m4
gr-usrp/apps/Makefile.am

index 6783e99a99b177344318ee56eb9e11640010a63e..3708dcad0d28eeceb6c1fdb27ffab51652393c48 100644 (file)
@@ -58,7 +58,8 @@ AC_DEFUN([GRC_USRP],[
     if test $passed != with; then
        dnl how and where to find INCLUDES and LA
        usrp_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/legacy \
-               -I\${abs_top_srcdir}/usrp/firmware/include"
+               -I\${abs_top_srcdir}/usrp/firmware/include \
+               -I\${abs_top_builddir}/usrp/host/lib/legacy"
         usrp_LA="\${abs_top_builddir}/usrp/host/lib/legacy/libusrp.la"
        usrp_inband_INCLUDES="-I\${abs_top_srcdir}/usrp/host/lib/inband"
        usrp_inband_LA="\${abs_top_builddir}/usrp/host/lib/inband/libusrp-inband.la"
index e1ac1b85531b290e4acf6382c04a58cbad12de6a..dfbfe1bf0b8f3c92623bc6e9b3069f2a3b875a02 100644 (file)
@@ -25,6 +25,7 @@ include $(top_srcdir)/Makefile.common
 AM_CPPFLAGS=$(STD_DEFINES_AND_INCLUDES) \
         -I$(top_srcdir)/gr-usrp/src \
         -I$(top_srcdir)/usrp/host/lib/legacy \
+        -I\${abs_top_builddir}/usrp/host/lib/legacy \
         -I$(top_srcdir)/usrp/firmware/include \
         $(WITH_INCLUDES)