added minimal qa code for gr_noise_source
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 16 Jan 2007 17:45:41 +0000 (17:45 +0000)
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>
Tue, 16 Jan 2007 17:45:41 +0000 (17:45 +0000)
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@4279 221aa14e-8319-0410-a670-987f0aec2ac5

gnuradio-core/src/python/gnuradio/gr/Makefile.am
gnuradio-core/src/python/gnuradio/gr/qa_noise.py [new file with mode: 0755]

index 5661cac5c3df1360b93c4adf2f41575673fbf7db..339fb81dd0e3df4454eb3533af8ac67e585db160 100644 (file)
@@ -74,6 +74,7 @@ noinst_PYTHON =                       \
        qa_message.py                   \
        qa_mute.py                      \
        qa_nlog10.py                    \
+       qa_noise.py                     \
        qa_packed_to_unpacked.py        \
        qa_pipe_fittings.py             \
        qa_pll_carriertracking.py       \
diff --git a/gnuradio-core/src/python/gnuradio/gr/qa_noise.py b/gnuradio-core/src/python/gnuradio/gr/qa_noise.py
new file mode 100755 (executable)
index 0000000..9a5007a
--- /dev/null
@@ -0,0 +1,39 @@
+#!/usr/bin/env python
+#
+# Copyright 2007 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+from gnuradio import gr, gr_unittest
+
+class test_noise_source(gr_unittest.TestCase):
+
+    def setUp (self):
+        self.fg = gr.flow_graph ()
+
+    def tearDown (self):
+        self.fg = None
+
+    def test_001(self):
+        # Just confirm that we can instantiate a noise source
+        op = gr.noise_source_f(gr.GR_GAUSSIAN, 10, 10)
+
+if __name__ == '__main__':
+    gr_unittest.main ()
+