tests: remove unnecessary use of "path_prepend_ ."
authorJim Meyering <meyering@redhat.com>
Mon, 1 Feb 2010 12:34:46 +0000 (13:34 +0100)
committerJim Meyering <meyering@redhat.com>
Wed, 3 Feb 2010 05:23:57 +0000 (06:23 +0100)
It is unnecessary, since Makefile.am's TESTS_ENVIRONMENT setting
already adds the top build directory, and besides, is only
marginally useful when running stand-alone, since it presumes
that the script is being run from the top build directory.
* tests/helin-segv: Remove unnecessary use of path_prepend_.
* tests/memcpy-abuse: Likewise.
* tests/trailing-nul: Likewise.
* tests/zdiff: Likewise.
* tests/zgrep-f: Likewise.

tests/helin-segv
tests/memcpy-abuse
tests/trailing-nul
tests/zdiff
tests/zgrep-f

index d6b14f6d167b55a496409407082934d62d53819b..4e448a51091c44e3ee7bbdbd9a8b72421d11fab3 100755 (executable)
@@ -23,7 +23,7 @@ if test "$VERBOSE" = yes; then
 fi
 
 : ${srcdir=.}
-. "$srcdir/tests/init.sh"; path_prepend_ .
+. "$srcdir/tests/init.sh"
 
 # This test case was provided by Aki Helin.
 printf '\037\235\220\0\0\0\304' > helin.gz || framework_failure
index 8f2abd5488f90d55639fb50744ff42cdfe54825f..95bc8ca4b80653cfe092494433496c09018fc586 100755 (executable)
@@ -24,7 +24,7 @@ if test "$VERBOSE" = yes; then
 fi
 
 : ${srcdir=.}
-. "$srcdir/tests/init.sh"; path_prepend_ .
+. "$srcdir/tests/init.sh"
 
 # The input must be larger than 32KiB and slightly
 # less uniform than e.g., all zeros.
index 83805dffbb01d2384e0383ed41fd46fc1a020a67..8106c290a77d78b26a7936cdf0e86fa6f5fff5bd 100755 (executable)
@@ -24,7 +24,7 @@ if test "$VERBOSE" = yes; then
 fi
 
 : ${srcdir=.}
-. "$srcdir/tests/init.sh"; path_prepend_ .
+. "$srcdir/tests/init.sh"
 
 (echo 0 | gzip; printf '\0') > 0.gz || framework_failure
 (echo 00 | gzip; printf '\0\0') > 00.gz || framework_failure
index da753c69bea2c93cb13a5bae728f7a514f31ffea..151d00dcf254ead1017774f4566b3a99cf3f91db 100755 (executable)
@@ -24,7 +24,7 @@ if test "$VERBOSE" = yes; then
 fi
 
 : ${srcdir=.}
-. "$srcdir/tests/init.sh"; path_prepend_ .
+. "$srcdir/tests/init.sh"
 
 echo a > a || framework_failure
 echo b > b || framework_failure
index 5f4b7a002bff819eb10626295d54d83e33986c57..0801e8dd55cdfac166507a53d6a14e579b99dbc5 100644 (file)
@@ -24,7 +24,7 @@ if test "$VERBOSE" = yes; then
 fi
 
 : ${srcdir=.}
-. "$srcdir/tests/init.sh"; path_prepend_ .
+. "$srcdir/tests/init.sh"
 
 echo needle > n || framework_failure
 echo needle > haystack || framework_failure