maint: prepare for gnulib's new tight-scope syntax-check rule
authorJim Meyering <meyering@redhat.com>
Mon, 9 May 2011 08:03:57 +0000 (10:03 +0200)
committerJim Meyering <meyering@redhat.com>
Mon, 9 May 2011 09:36:05 +0000 (11:36 +0200)
* cfg.mk (_gl_TS_dir): Define.
(_gl_TS_unmarked_extern_vars): Define.

cfg.mk

diff --git a/cfg.mk b/cfg.mk
index f9e7d253b3940cad6fd14ddf5a97d7cbf71bb674..7433015a4e7699a5e0d5ce5469d528ef1eb527a1 100644 (file)
--- a/cfg.mk
+++ b/cfg.mk
@@ -74,3 +74,10 @@ exclude_file_name_regexp--sc_require_config_h_first = ^lib/match\.c$$
 exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF = \
   ^tests/hufts-segv\.gz$$
 exclude_file_name_regexp--sc_prohibit_strcmp = ^gzip\.c$$
+
+# Tell the tight_scope rule that sources are in ".".
+export _gl_TS_dir = .
+
+# Tell the tight_scope rule that these variables are deliberately "extern".
+export _gl_TS_unmarked_extern_vars = \
+  block_start d_buf inbuf outbuf prev read_buf strstart window